Change default boot setting?

I have a dual boot set up running on a single HDD which defaults to booting up in OpenSuSE my secondary boot is to Windows 7.
You may ask why I bother with Windows, the reason is I have a wife with lady friends, who all have Windows 7 on their Laptops, and do not wish to change from what they have struggled to learn. Sorting out their problems is a lot easier when I have access to the same system on my PC
They are all wishing to take advantage of the free update to Windows 10 that Microsoft have offered. Trying the free update on my system fails and, according to the error code given, it is because it is a dual boot system with linux. It suggest that if the boot preference is given to Windows the update will work.
Can anyone tell me if this is possible and if so please explain how to do it. I have looked in the Bios but this only seems to allow me to choose which HDD boots not which partition.
Thanking you in anticipation,

merkland

Are you using BIOS or EFI boot? In case of BIOS - is GRUB installed in MBR or in partition?

On Mon, 17 Aug 2015 10:36:01 GMT
merkland <merkland@no-mx.forums.microfocus.com> wrote:

>
> I have a dual boot set up running on a single HDD which defaults to
> booting up in OpenSuSE my secondary boot is to Windows 7.
> You may ask why I bother with Windows, the reason is I have a wife
> with lady friends, who all have Windows 7 on their Laptops, and do
> not wish to change from what they have struggled to learn. Sorting
> out their problems is a lot easier when I have access to the same
> system on my PC
>
> They are all wishing to take advantage of the free update to Windows
> 10 that Microsoft have offered. Trying the free update on my system
> fails and, according to the error code given, it is because it is a
> dual boot system with linux. It suggest that if the boot preference
> is given to Windows the update will work.
> Can anyone tell me if this is possible and if so please explain how to
> do it. I have looked in the Bios but this only seems to allow me to
> choose which HDD boots not which partition.
> Thanking you in anticipation,
>

Can you supply the error code? Was it C190011F?

I have successfully upgraded W7 to W10 on two machines. Both have GRUB2
booting as default to openSUSE with a couple of other openSUSE systems
on the menu in addition to Windows.

The upgrade on the laptop went without a hitch but the desktop failed
C190011F. This was eventually got round by downloading a tool from
https://www.microsoft.com/en-us/software-download/windows10 and burning
the upgrade onto a thumb-drive and installing from that. *

For an upgrade, rather than a new install, you’ll need to insert the
drive after booting into Windows. I just opened the file manager and
double-clicked on the “setup” file and off it went.

It needed 3 or 4 reboots so, as default boot is openSUSE, I had to keep
an eye on it to make sure it booted into Windows each time. OK, yes, I
should have gone into YaST and made Windows the default but I didn’t
think of it until after I’d started the installation.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.4; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)
*

Thank you both for your responses, you will have to forgive me if I seem a little slow both in responding and understanding - once you pass 70 the old brain does not seem to work as well and forgets things very quickly!

To reply to arvidjaar first, these are the settings for the boot loader in YAST:

Boot Loader is Grub2 and Boot from Root Partition is ticked,
Set active Flag in Partition Table for Boot Partition is ticked,
Write generic Boot Code to MBR is ticked.

Perhaps you have an easy solution for me?

In reply to cloddy, the error code is 800703ED. According to Google this indicates that in a duel boot system on a single drive the windows partition is not active and therefore the update will not work. The solution suggested is to activate the windows partition - I have still to find out how to do this.
Otherwise I have still to look at your suggested solution through the download.

merkland.

Change the active partition to Windows.

Then you won’t be able to boot opensuse until you change it back.

To change the active partition, I would use “fdisk” as in:

# fdisk /dev/sda

Okay, here’s an example from one of my computers (with similar boot settings except that I left the Windows partition active):


# fdisk /dev/sda
  ##### some output from fdisk appears here, but not important so not quoted ###

Command (m for help): p


Disk /dev/sda: 750.2 GB, 750156374016 bytes, 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk label type: dos
Disk identifier: 0xbf1c9325


   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048     1026047      512000   83  Linux
/dev/sda2   *     1026048   126855167    62914560    7  HPFS/NTFS/exFAT
/dev/sda3       126857214  1465149167   669145977    5  Extended
Partition 3 does not start on physical sector boundary.
/dev/sda5       126857216   130953215     2048000    7  HPFS/NTFS/exFAT
/dev/sda6       130955264   132003839      524288   83  Linux
/dev/sda7       132005888   446578687   157286400   8e  Linux LVM
/dev/sda8       446580736   530466815    41943040   83  Linux
/dev/sda9       530468864  1465149167   467340152   83  Linux

Note that the “p” command prints the partition information.
That output shows that “/dev/sda2” is the active partition. If I wanted to change that to “/dev/sda1”, then I would use:


Command (m for help): a
Partition number (1-3,5-9, default 9): 2


Command (m for help): a
Partition number (1-3,5-9, default 9): 1


Command (m for help): p

That final “p” is to again print the information, which should now show the “*” against partition “/dev/sda1”

To save those changes, I would use the “w” command. However, in this case I don’t want to save them, so I will use the “q” command (to quit without saving).

If you find you are confused while trying this, you can also use CTRL-C to abort, which won’t save any changes. So it won’t hurt to do a trial run and then abort.

To change back, boot from a live CD or similar (or your install media in rescue mode), and use “fdisk” again to reverse the changes.

As to how I boot opensuse when Windows is active? I added an entry to the Windows boot manager. That allows me to use opensuse and keep Windows happy at the same time. When Windows starts it prompts me on whether to boot Windows or linux.