Change date format in thunderbird!

Hello everyone! I am using kde 4.4.4 and thunderbird. I would like to change how thunderbird shows the date. Now it is shown as 12.31.1980 and I would like to use 31.12.1980.

I am not sure if this is a thunderbird option (didnt find any) or a gtk option and how to configure that using kde.

I would like to thank you in advance for your help

Best Regards
Alex

i think most applications get their hint on how to display dates from
the operating system settings on location…i do not know about 4.4.4
but there was in 3.5 and may still be a setup option in Personal
Settings - Configure Desktop, go (something like)
“Region & Accessibility” >
"Country/Region & Language >
“Time & Dates” (tab)
and select the formats you wish, then click “Apply”

if that doesn’t impact how thunderbird shows them, then i guess you
have to look deeper into the thunderbird docs


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

Thanks a lot, just did it

After rebooting the system I cannot see what I was expecting to :frowning:
IT seems that thunderbird is reading some gtk configuration file.

Best Regards
Alex

There is a Mozilla howto on this, search for it. It can be configured within Thunderbird, but I think you need to go to the config editor.

I’m relatively new to openSUSE and I’m using Gnome so please forgive me if this is not relevant. To change the date format in Thunderbird to what you want I did the following:

Open Yast and choose Language. When I installed 11.3 I choose English (US). In language I changed Primary Language to English (UK). I left the 2 check boxes below unchecked. I then rebooted and got the date format you want.

As far as I can tell there are no other effects from changing this. Hope this helps.

GeneBenson wrote:
> I then rebooted and got the date format you want.

thanks for your input…we like helping each other here…since you
say you are relatively new to openSUSE (welcome!) let me throw out
that most (many?) things we change in Linux may/will/should take
affect without requiring a reboot…

now, i know that whatever other operating system you are used to only
reads configuration files once per boot and in that system one must
boot to force the system to pay attention…

however, with some few exceptions (like a kernel change) the most one
must do is shutdown/restart the X server (do that with a user log out
and re-log in, not a shutdown or re-boot)…

in many cases (i think this would be one) you would only have to
shutdown and restart thunderbird (or maybe just close one email and
open another)…

i know multiple rebooting is a hard to break habit, but next time
check and see if your change takes affect without you doing anything
(other than making the change in the right place), or then try just
closing/opening the application, or log out and in…

try it…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

On 2010-09-03 17:36, ken yap wrote:
>
> There is a Mozilla howto on this, search for it. It can be configured
> within Thunderbird, but I think you need to go to the config editor.

My thunderbird is taking the date settings from the environment locale settings (LC_TIME), same as
gnome (which do not need to be changed globally):

cer@Elessar:~> locale
LANG=en_US.UTF-8

LC_TIME=en_DK.UTF-8

The result you can see in the reply line above.

As to a setting in Th. itself, that would be nice to know about.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Thanks for the tip DenverD. Being an old Windows reprobate I think rebooting is pretty much hard wired in me. I will try to un-learn some of those bad habits I picked from my MS daze.

GeneBenson wrote:
> Thanks for the tip DenverD.

welcome…thanks for taking it the way i intended…i’ve just seen
folks come here and in not so many days they have found a whiz-bang
somewhere, packed up in a zip file and the instructions say to copy
this and that to here and there and then reboot…

which sounds reasonable to the new folks but sets off all kinds of RED
WARNING FLAGS to old folks…because, it means the thing sure wasn’t
made by a seasoned *nix hacker and since it requires a reboot it
just might be ROOT KIT hidden in a socially engineered self foot
shooting thingy…brrrrrrrrrrrrrrr


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]