Certificate Issues After Updates

Has anyone else had certificate issues after the latest round of updates? I applied the updates yesterday, rebooted, at which point Evolution wouldn’t connect to my work Exchange server anymore, claiming the signing certificate was invalid. Gnome online-accounts also claimed there were problems with the Exchange account (the only way I could get my Exchange account to work was by configuring it through Online Accounts, doing it directly in Evolution wasn’t working, I wish I could NOT use Exchange, but I have to for work, don’t judge me).

I rolled back to the pre-update snapshot and now it is working just fine. Below is the list of updates that were applied between the system working, and the system not working. Not sure if that is helpful or not. Is this something I should file a bug report about?

Sorry if my questions are dumb, I’m new to the Suse world after having been an Arch user for quite some time.

S | Repository | Name                              | Current Version  | Available Version | Arch  
--+------------+-----------------------------------+------------------+-------------------+-------
v | repo-oss   | ruby2.1                           | 2.1.5-1.4        | 2.1.5-2.1         | x86_64
v | repo-oss   | python-xml                        | 2.7.9-2.2        | 2.7.9-2.3         | x86_64
v | repo-oss   | python-base                       | 2.7.9-2.2        | 2.7.9-2.3         | x86_64
v | repo-oss   | pulseaudio-utils                  | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio-module-zeroconf        | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio-module-x11             | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio-module-lirc            | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio-module-gconf           | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio-module-bluetooth       | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio-bash-completion        | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | pulseaudio                        | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | yast2-hardware-detection          | 3.1.5-1.2        | 3.1.6-1.1         | x86_64
v | repo-oss   | yast2-country-data                | 3.1.18-1.1       | 3.1.19-1.1        | x86_64
v | repo-oss   | yast2-country                     | 3.1.18-1.1       | 3.1.19-1.1        | x86_64
v | repo-oss   | typelib-1_0-Caribou-1_0           | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | perl-base                         | 5.20.1-1.4       | 5.20.1-2.1        | x86_64
v | repo-oss   | perl                              | 5.20.1-1.4       | 5.20.1-2.1        | x86_64
v | repo-oss   | openal-soft                       | 1.15.1-5.2       | 1.16.0-1.1        | x86_64
v | repo-oss   | openSUSE-release-ftp              | 20150216-1.2     | 20150220-1.2      | x86_64
v | repo-oss   | openSUSE-release                  | 20150216-1.2     | 20150220-1.2      | x86_64
v | repo-oss   | ncurses-utils                     | 5.9-59.2         | 5.9-60.1          | x86_64
v | repo-oss   | terminfo-base                     | 5.9-59.2         | 5.9-60.1          | x86_64
v | repo-oss   | terminfo                          | 5.9-59.2         | 5.9-60.1          | x86_64
v | repo-oss   | tar                               | 1.28-6.1         | 1.28-7.1          | x86_64
v | repo-oss   | sysconfig-netconfig               | 0.83.8-1.1       | 0.83.8-2.1        | x86_64
v | repo-oss   | sysconfig                         | 0.83.8-1.1       | 0.83.8-2.1        | x86_64
v | repo-oss   | ruby2.1-stdlib                    | 2.1.5-1.4        | 2.1.5-2.1         | x86_64
v | repo-oss   | mono-winfxcore                    | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-winforms                     | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-web                          | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-wcf                          | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-mvc                          | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-extras                       | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-data-sqlite                  | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-data                         | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | mono-core                         | 3.10.0-2.2       | 3.10.0-2.4        | x86_64
v | repo-oss   | libyui-ncurses6                   | 2.46.8-1.2       | 2.46.10-1.1       | x86_64
v | repo-oss   | libtasn1-6                        | 4.2-1.2          | 4.2-2.1           | x86_64
v | repo-oss   | libtasn1                          | 4.2-1.2          | 4.2-2.1           | x86_64
v | repo-oss   | libstorage6                       | 2.25.20-1.1      | 2.25.20-2.1       | x86_64
v | repo-oss   | libstorage-ruby                   | 2.25.20-1.1      | 2.25.20-2.1       | x86_64
v | repo-oss   | libsqlite3-0                      | 3.8.8.1-1.1      | 3.8.8.2-1.1       | x86_64
v | repo-oss   | libruby2_1-2_1                    | 2.1.5-1.4        | 2.1.5-2.1         | x86_64
v | repo-oss   | librsvg-2-2                       | 2.40.6-1.2       | 2.40.7-1.1        | x86_64
v | repo-oss   | libreoffice-writer-extensions     | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-writer                | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-pyuno                 | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-math                  | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-mailmerge             | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-impress               | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-gnome                 | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-filters-optional      | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-draw                  | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-calc-extensions       | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-calc                  | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-base-drivers-mysql    | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice-base                  | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libreoffice                       | 4.4.0.3-1.1      | 4.4.0.3-2.1       | x86_64
v | repo-oss   | libqt5-qtbase-platformtheme-gtk2  | 5.4.0-4.1        | 5.4.0-5.1         | x86_64
v | repo-oss   | libpython2_7-1_0-32bit            | 2.7.9-2.2        | 2.7.9-2.3         | x86_64
v | repo-oss   | libpython2_7-1_0                  | 2.7.9-2.2        | 2.7.9-2.3         | x86_64
v | repo-oss   | libpulse0                         | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | libpulse-mainloop-glib0           | 5.99.3-1.1       | 6.0-1.1           | x86_64
v | repo-oss   | libpipeline1                      | 1.2.6-3.2        | 1.4.0-1.1         | x86_64
v | repo-oss   | libopenal1                        | 1.15.1-5.2       | 1.16.0-1.1        | x86_64
v | repo-oss   | libncurses6                       | 5.9-59.2         | 5.9-60.1          | x86_64
v | repo-oss   | libncurses5                       | 5.9-59.2         | 5.9-60.1          | x86_64
v | repo-oss   | libncurses5-32bit                 | 5.9-59.2         | 5.9-60.1          | x86_64
v | repo-oss   | libhavege1                        | 1.9.1-8.3        | 1.9.1-9.1         | x86_64
v | repo-oss   | libelf1-32bit                     | 0.161-1.2        | 0.161-2.1         | x86_64
v | repo-oss   | libelf1                           | 0.161-1.2        | 0.161-2.1         | x86_64
v | repo-oss   | libdw1                            | 0.161-1.2        | 0.161-2.1         | x86_64
v | repo-oss   | libcurl4                          | 7.40.0-1.1       | 7.40.0-2.1        | x86_64
v | repo-oss   | libcaribou0                       | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | libbluray1                        | 0.7.0-1.1        | 0.7.0-2.1         | x86_64
v | repo-oss   | libasm1                           | 0.161-1.2        | 0.161-2.1         | x86_64
v | repo-oss   | libQt5Widgets5                    | 5.4.0-4.1        | 5.4.0-5.1         | x86_64
v | repo-oss   | libQt5Gui5                        | 5.4.0-4.1        | 5.4.0-5.1         | x86_64
v | repo-oss   | libQt5DBus5                       | 5.4.0-4.1        | 5.4.0-5.1         | x86_64
v | repo-oss   | libQt5Core5                       | 5.4.0-4.1        | 5.4.0-5.1         | x86_64
v | repo-oss   | kernel-desktop-devel              | 3.18.3-2.3       | 3.19.0-2.4        | x86_64
v | repo-oss   | kernel-desktop                    | 3.18.3-2.3       | 3.19.0-2.4        | x86_64
v | repo-oss   | kbd                               | 2.0.2-7.1        | 2.0.2-8.1         | x86_64
v | repo-oss   | java-1_8_0-openjdk-headless       | 1.8.0.40~b25-1.1 | 1.8.0.40~b25-2.1  | x86_64
v | repo-oss   | java-1_8_0-openjdk                | 1.8.0.40~b25-1.1 | 1.8.0.40~b25-2.1  | x86_64
v | repo-oss   | haveged                           | 1.9.1-8.3        | 1.9.1-9.1         | x86_64
v | repo-oss   | grub2-x86_64-efi                  | 2.02~beta2-32.1  | 2.02~beta2-33.1   | x86_64
v | repo-oss   | grub2-i386-pc                     | 2.02~beta2-32.1  | 2.02~beta2-33.1   | x86_64
v | repo-oss   | grub2                             | 2.02~beta2-32.1  | 2.02~beta2-33.1   | x86_64
v | repo-oss   | gnome-font-viewer                 | 3.14.0-1.1       | 3.14.1-1.1        | x86_64
v | repo-oss   | gnome-control-center-user-faces   | 3.14.2-3.1       | 3.14.2-4.1        | x86_64
v | repo-oss   | gnome-control-center-color        | 3.14.2-3.1       | 3.14.2-4.1        | x86_64
v | repo-oss   | gnome-control-center              | 3.14.2-3.1       | 3.14.2-4.1        | x86_64
v | repo-oss   | gdk-pixbuf-loader-rsvg            | 2.40.6-1.2       | 2.40.7-1.1        | x86_64
v | repo-oss   | gcc                               | 4.8-8.2          | 4.8-9.1           | x86_64
v | repo-oss   | elfutils                          | 0.161-1.2        | 0.161-2.1         | x86_64
v | repo-oss   | dracut                            | 037-29.1         | 037-30.1          | x86_64
v | repo-oss   | dos2unix                          | 7.1-1.1          | 7.2-1.1           | x86_64
v | repo-oss   | curl                              | 7.40.0-1.1       | 7.40.0-2.1        | x86_64
v | repo-oss   | cups-libs-32bit                   | 1.5.4-26.2       | 2.0.2-1.1         | x86_64
v | repo-oss   | cups-libs                         | 1.5.4-26.2       | 2.0.2-1.1         | x86_64
v | repo-oss   | cups-client                       | 1.5.4-26.2       | 2.0.2-1.1         | x86_64
v | repo-oss   | cups                              | 1.5.4-26.2       | 2.0.2-1.1         | x86_64
v | repo-oss   | cpp                               | 4.8-8.2          | 4.8-9.1           | x86_64
v | repo-oss   | caribou-gtk3-module               | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | caribou-gtk2-module               | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | caribou-gtk-module-common         | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | caribou-common                    | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | caribou                           | 0.4.16-1.2       | 0.4.17-1.1        | x86_64
v | repo-oss   | autofs                            | 5.1.0-5.1        | 5.1.0-6.1         | x86_64
v | repo-oss   | python3-setuptools                | 12.0.5-1.1       | 12.2-1.1          | noarch
v | repo-oss   | libreoffice-l10n-en               | 4.4.0.3-1.1      | 4.4.0.3-2.1       | noarch
v | repo-oss   | libreoffice-icon-theme-tango      | 4.4.0.3-1.1      | 4.4.0.3-2.1       | noarch
v | repo-oss   | libreoffice-icon-theme-sifr       | 4.4.0.3-1.1      | 4.4.0.3-2.1       | noarch
v | repo-oss   | libreoffice-icon-theme-hicontrast | 4.4.0.3-1.1      | 4.4.0.3-2.1       | noarch
v | repo-oss   | libreoffice-icon-theme-galaxy     | 4.4.0.3-1.1      | 4.4.0.3-2.1       | noarch
v | repo-oss   | kernel-macros                     | 3.18.3-2.3       | 3.19.0-2.4        | noarch
v | repo-oss   | kernel-devel                      | 3.18.3-2.3       | 3.19.0-2.4        | noarch
v | repo-oss   | grub2-snapper-plugin              | 2.02~beta2-32.1  | 2.02~beta2-33.1   | noarch
v | repo-oss   | bundle-lang-gnome-en              | 13.2-7.20        | 13.2-7.21         | noarch
v | repo-oss   | bundle-lang-common-en             | 13.2-7.19        | 13.2-7.20         | noarch

I hate to do this… but… bump.

Anyone have any ideas? It doesn’t even look to me like any of the packages on that list should affect certificate handling. Am I wrong about that?

Well, I did another zypper dup today and now things seem to be working… so… I don’t know what the hell is going on. Thanks for the helpful suggestions though :sarcastic: