Certain videos downloaded from YouTube won't play -- getting error message

I’ve noticed recently when using Kaffeine that quite a few videos I download from YouTube won’t play and, instead, generate this message (each message differs only in the file name):

Cannot find demux plugin for MRL “file:///home/gil/Desktop/Didier_Zokora_intikam_-_YouTube.flv”.

If I try using KMplayer rather than Kaffeine I don’t get the message, just a black screen.

Other flash videos that I’ve downloaded in the past play just fine using either Kaffeine or KMplayer.

I’m stumped. Any ideas?

SuSE 11.4 64 bit.
Kaffeine v. 1.1 Using KDE Development Platform 4.6.00 (4.6.0) "release 6

KMplayer v. 0.11.3c

Oh, and I’m using the Firefox extension Downloadhelper v 4.9.9 to grab the video from the Internet.

Many thanks.

Oh, I forgot to say that I did search these forums and found several references to the problem, the most recent from January of this year under the thread title:
Kaffiene error when playing certain flv videos (yes, there is a typo in the thread name). But there have been no replies to that January request for help.

I also searched on Google and found many references to the problem but suggestions for Ubuntu, not for SuSE.

Thanks for your help.


OK, let me try to post this again. The first attempt seems to have failed.

I searched Youtube for “Didier_Zokora_intikam” and I found two possible matches:
Didier Zokora intikam - YouTube
Didier Zokora intikam - YouTube
Is one of those the video you are after?

I can say that it works here. Both in Kaffeine and in SMPlayer.

SMPlayer tells me that it uses “lavfprep - libavformat preferred demuxer”. Searching YaST for “lavfpref” yields no results. Searching for “libavformat” however finds the packages
So, maybe that is what you need? They come both from Packman.

Use smplayer or vlc

Thanks for reply. Perhaps I was not clear in my posts.

Yes, that is the video clip.

I can play it by clicking on either of the YouTube links you provided (or on any of numerous other places on the Internet where the video appears). Playing directly from the Internet has never been the problem .

The problem comes when I save (download) the video to my desktop. From there this flash video (and numerous others) won’t play. But others that were downloaded weeks or months ago play just fine.

Now, interestingly the links you provided offer me an mp4 version (which was not offered at any of the links I had used when viewing the video clip after it was posted to YouTube a few days ago). That mp4 version downloaded to the desktop and played just fine using either Kaffeine or KMplayer. But the .flv version from both links doesn’t play.

So the issue still is how to make the flash version of this video (and other clips) play when downloaded to my desktop.


Thx, CAF, but neither SMplayer nor VLC will play this flash video clip. However, other flash videos and other formats play just fine.



I have libavformat53 on the pooter. I do not have libavformat52.

Is “53” an updated version that replaces “52,” or should I have them both?


I downloaded the clips as .flv and then tried to play them too. Which worked both in Kaffeine and SMPlayer. I think it was actually me who wasn’t very clear.

I have both 52 and 53 showing in the Packman repo (11.4; 64bit). To be honest I have no idea if you need them both or if one obsoletes the other.

I just tried to play the same .flv on my SuSE 12.0 64 bit laptop. Same error message. Same problem. Won’t play in Kaffeine or KMplayer.

Very frustrating.


I downloaded and looked at the video and it is an h264 encoded @ 640x360, with aac encoded audio.

I tried playing it on my kaffeine and it also did not play at first. Likely the h264 codec or aac audio codec was missing from kaffeine. So I then installed:

  • phonon-backend-xine-4.4.4-8.1.2
  • libxine1-codecs-
  • kdebase4-runtime-xine-4.7.2-3.4.2

and one of those fixed the problem (or maybe all of the above) as the downloaded video plays now in kaffeine with no problem (this is on a 64-bit openSUSE-12.1 with the normal KDE-4.7.2). My version of kaffeine is:


Again, thanks for the reply.

I checked my 12.1 lappy and I have exactly the same as you. But the video won’t play on my system. ;o(
I’m going to check the tutorial you provided in your other post.

Again, thanks.

I followed the instructions carefully and let the system do all the updates on my 12.1 lappy.

But I’m still getting the same error message with Kaffeine, and KMplayer still shows nothing but a black screen.

Bizarre, isn’t it?


But there is more to this …

For example, here is my KDE settings under multimedia:

For a video:

The audio hardware device settings in KDE:

and I am currently using the VLC backend:

which means I have installed vlc-aout-pulse from the Packman packager repository.

… but there is more …

I have also configured pavucontrol to work with my KDE selected hardware audio device.

I checked my settings. Screens 1 and 2 are the same as yours. My screen 3 shows GStreamer rather than VLC (but I guess that’s because I choose to use Kaffeine and KMplayer rather than VLC).

Note that I also do have vlc-aout-pulse installed as well as pavucontrol. Still, the video won’t play in Kaffeine or KMplayer or VLC. However, other videos play just fine an all three players. It’s just this .flv and others recently downloaded from YouTube that won’t play anywhere.


For vlc to be available for KDE applications then one needs phonon-backend-vlc and vlc-aout-pulse. And then restart KDE.

wrt vlc, what output video mode do you have selected (under vlc > tools > preferences > video) ? Its possible gstreamer struggles with the video codec (or audio codec) in the files you are downloading, in which case, which gstreamer rpms do you have installed ?

CPU, sorry for the delayed reply. Been up to my neck in alligators at work.

Regarding VLC (which I normally do not use): I do have phonon-backend-vlc and vlc-aout-pulse on the pooter. Still, VLC won’t play the videos in question and I get an error message that says:

*No suitable decoder module:
VLC does not support the audio or video format “undf”. Unfortunately there is no way for you to fix this.

No suitable decoder module:

VLC does not support the audio or video format “undf”. Unfortunately there is no way for you to fix this.

As for the video output, the drop-down box for Display shows “Default” and for Video Deinterlacing “off” and for Mode “blend.”

As for gstreamer rpms I have the following on the pooter:


Hope this information helps.

OK, then default is likely not working for you. Try ‘x11 video output’ or ‘XVideo output’ or another of the settings.

I don’t use gstreamer. So it does not help me understand why this ‘just works’ for me and it does not ‘just work’ for you.

Someone who successfully uses gstreamer will need to help you there, because I don’t use gstreamer and hence can not (help with gstreamer).