Certain plasmoids stopped working (time related?)

I’ve recently started running OpenSUSE 11.1, but since installation I’ve managed to screw up something which has caused certain plasmoids to stop working correctly. I haven’t done a comprehensive check of every plasmoid installed on my system, but I’ve tried a few and, barring the ones that don’t work anyway because of the “Could not create a Python ScriptEngine…” error, they all worked fine- except, it seems, for ones relating to time (though this may not actually be the case because, as noted above I didn’t yet try every plasmoid currently avaliable to me). The ones which seem to be broken, and the ways in which they’re broken are:

Digital clock: In default lower panel or on desktop, no graphic is rendered for it (except the background). Hovering over it shows the time as “00:00”, clicking on it shows a calendar. Calendar is correct

Analogue clock: On desktop, draws clock graphics, but stays at 12 constantly. Clicking it correctly shows the calendar.

Binary clock: Draws grid only, no time indicator dots, or squares, or whatever it draws to show on bits (never used it before breaking it)

Luna: Only draws background, no graphics for the moon are shown.

There might be a couple of others too that I don’t know of. I’ve tested stuff like Notes, calculator, Now Playing, Colour Picker seem to work fine. The battery monitor may also be playing up- it says “N/A” instead of showing the battery charge graphic (this is a laptop), and doesn’t begin displaying even if I remove the mains adapter so that it’s running off battery.

The system has the time fine- correct time is displayed under System Settings > Date & Time etc.

If anyone has any ideas where to even start with this I’d really appreciate help. I did at one point manage to break things by installing a bunch of KDE packages from, I think, the KDE repository, however I went through everything and reverted entirely to versions from repo-oss and repo-update, and looking in YaST’s list of packages installed on my machine I’m pretty sure all the offending packages have gone. Also, I’m quite sure that these widgets still worked after the revert, but I could be mistaken.

Thanks! :slight_smile:

Oops, forgot to mention- I’m running KDE 4.1.3 as initially installed :slight_smile:

Oops, forgot to mention- I’m running KDE 4.1.3 as initially installed

I thought this might be the case from your original post. Plasmoids can break if qt and/or kdelibs package versions conflict.

I would recommend upgrading to KDE4.2 or KDE4.3 to start with. If you do a search, there are numerous HOW TOs concerning this topic.

It would also be wise to let the forum see your current list of repos. Often these need adjusting as well.

zypper lr --details

Zypper’s repository list:

# | Alias        | Name                  | Enabled | Refresh | Priority | Type   | URI                                        | Service
1 | Packman      | Packman               | Yes     | Yes     |   99     | rpm-md | http://packman.jacobs-university.de/suse/11.1/                           |
2 | WINE         | WINE                  | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.1/ |
3 | libDVDCSS    | libDVDCSS             | No      | No      |   99     | rpm-md | http://suse.linuxin.dk/repo/11.1                                        |
4 | repo-debug   | openSUSE-11.1-Debug   | No      | No      |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/           |
5 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/             |
6 | repo-oss     | openSUSE-11.1-Oss     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                 |
7 | repo-source  | openSUSE-11.1-Source  | No      | No      |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/          |
8 | repo-update  | openSUSE-11.1-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                       

(there’s probably at least one in there which is being refreshed but doesn’t need to be, or similar ahemclumsyclicking

Updating doesn’t sound like a bad idea. I’ll go and read a howto and post back after.

Okay, on KDE 4.2 now, the plasmoids are working now. Also as an added bonus I can actually get Amarok 4.2 to output sound now.

That seems to solve the issues, thanks :slight_smile:

Good work. (I hear KDE4.3 is even more polished, but I’m staying with KDE4.2.4 for now).