Certain Configured programs won't start at bootup

I have to reconfigure Alsaconf everytime I
reboot or I get no sound. Also have to run the vmware configuration file everytime i boot.
Also used to stay configured.
using kde 4.3. This is an annoyance but not the worse thing in the world. is there away to make alsa start at boot like it is supposed to ans a way to stop vmware 2.0 from needing to be configured every time i reboot?
It has that stupid error that says the kernel is wrong you say continue anyway and then it works. the kernel is right this has been a bug in vmware 2.0 since it was released.:open_mouth:

Next time you boot, instead of reconfiguring alsa, open a gnome-terminal or a kde konsole and type:
su -c ‘rcalsasound restart’ and enter root password when prompted for a password. Does that work? If so, I can propse a way to have it run every boot.

Maybe you don’t have it configured to start automatically?

Yast > System > System Services

Click the “Expert Mode” radio button

Scroll nearly to the bottom of the list and you’ll likely see the Alsasound service, but not enabled and not running.

Click the Set/Reset button and enable the service (which will set it to start automatically on boot).

If you want to start the service immediately use the left button.

While in this applet, you might as well check to make sure your other services are configured correctly as well.

Not sure what you’re referring to about the vmware configuration file, is this install in a VM or are you running VMware on SuSE?

No vmware on suse. So I can use an xp desktop. Everytime i reboot I have to rerun the .pl configuration file.