Certain apps' fonts look like crap (gtk apps).

I just installed openSUSE 11.1 with KDE4 (and I’m loving it!! Just had to get that out,) but fonts in firefox and openoffice look like crap, so I’m assuming there’s some discrepancy between the way KDE and GTK apps’ fonts are rendered. I want to turn on the (… please excuse me for this:) clear-type-font-thingy that makes fonts look big and smooth (…!)

I would attach a pic to show the difference, but I don’t know how to do that at the moment. Anyhow, Is there a way to turn on super-sexy-fonts for GTK apps? Or for Firefox and OpenOffice?

These are my settings and everything looks great


screens can be taken with the print Screen key and upload to a site like I use here

Nice fonts, I 've incorporated them into my settings, thanks!

Still, though, it’s harder to distinguish the fonts on GTK apps than it is on my KDE apps. I took a snapshot of konqueror compared to firefox:
The image makes the fonts appear less distinguishable than they really are, so just know that in actuality the firefox fonts looks 2x as bad and the konqueror fonts look 2x as good compared to how they appear in the pic.

Here is my comparison - seems the other way for me:

I don’t know why, but the GTK fonts just don’t appear as smoothly as the KDE ones. It’s not a really big deal, but I use firefox a lot and it’s just “noticeable” – maybe I’m just being too obsessive compulsive about it…

I’m still looking to even things out though, lol.

I believe the problem is that anti-aliasing is on for KDE apps, but is nonfunctional for the GTK apps.

(sorry for 2x posting, I couldn’t find the edit button)

I solved the problem! I installed gnome-control-center (… and all of it’s dependencies) and ran ran the “gnome-appearance-properties” from the terminal, and tweaked the level of “hinting” to slight, used subpixel-soomething-or-the-other (cause I’m on an LCD) and viola: consistency!! Problem solved!!

don’t know how to or whether I can set the thread to “solved” but my problems have been… and sorry for 3x posts in a row as the same goes for editing posts. Viva la chameleon!!

You’ll like linux.

Try to get your boot down to under 8 seconds.

Ready… Go!


Uh oh – For my free-time’s sake I’ll pretend you didn’t suggest that, heheh.

Despite all the progress I’ve made, it appears that I’ve run into another problem: installing the gnome-appearance-properties (and it’s many dependencies) has the unfortunate side-effect of giving it complete control of the style/widget decision-making. So aside from the window decorations, I can’t control how my gtk apps look anymore :(. Seeing as how I have no idea how to roll-back the changes I’ve made, it looks like I’ll have to fresh-install and start from scratch.

After a fresh restart (and updates), I’ve made heaps of progress. For some reason, the “hinting” settings in KDE and Gnome are completely reversed!!

At least, that’s been my experience thus far. When I select “slight” hinting, the KDE fonts become much “thinner” but the GTK fonts become much “thicker”. Now when I select “full” hinting, the KDE fonts become much “thicker” and the GTK fonts become much “thinner” – and the differential between the two are just about the same!

I don’t know why that is, but it sucks - I like think fonts everywhere… I guess I really can’t have my cake and eat it too, so I set the “hinting” to medium and everything is uniform. Things look pretty good, though as the fonts are readable, but I’m still slightly disappointed.

Hopefully things will be different once I upgrade to KDE 4.2!

Just thought it worth a mention. On my main box running F10 which has Gnome and kde4 I have different settings than my screen earlier (from my laptop which is suse and only kde4.2)

F10 looks better with the same fonts (liberation)
But anti-aliasing = system settings
DPI= Disabled

Maybe worth a try.

I have those settings, and the font rendering still isn’t quite uniform, but after upgrading to KDE 4.2 they’ve come quite closer to each other. I have hinting on “slight” and the fonts for GTK apps are only a little thicker than their KDE counterparts - which is much better behavior than before, I’m satisfied with this though so everything’s cool now! KDE 4.2 is great, can’t wait for 4.3 support!

Out of curiosity what settings have you in GTK Styles and Fonts?

I don’t think you were asking me, but:
Default - For me that is Use kde in gtk