cd's don't auto mount; opensuse 11.1 x86-64, kde 4.1


I’ve been encountering several problems with CD’s today. Let’s start with auto-mounting them. They don’t. Based on various web searching I tried adding my user to both the audio and disk groups, but that hasn’t helped.


  1. What is a sure-fire “canonical” test, with a kde app like konqueror or dolphin or what not, to see if a cd’s been mounted?

  2. How do I fix the problem?

Thanks, and happy year++,

I have similar issues plus some more …

I updated my suse 11 to 11.1 and it complained about the boot loader (LILO) and some entries in my fstab my …
I found that the proc line was freezing the mounting process.

I cannot mount DVD or CD when suse is up, though it can boot from the DVD … Bizarre. Also, no USB drives can be mounted. HELP.

I also tried to update the ATI driver using the downloaded files from the ATI website and I cannot run googleearth anymore.
How can I revert the effect of installing the driver ?

One more thing: some of the programs I was running with WINE on 11 have graphical issues now on 11.1 ! Bummer. I need help on this.

I had this problem.

Its something to do with jexec
(64 bit java binary execution service)

When it starts at boot it tries to start twice, once in
a call in /etc/modules.conf



install binfmt_misc /sbin/modprobe --ignore-install binfmt_misc && { mount -t binfmt_misc none /proc/sys/fs/binfmt_misc; }
remove binfmt_misc { umount /proc/sys/fs/binfmt_misc; } ; /sbin/modprobe -r --ignore-remove binfmt_misc

and apparently once through a jexec script, and these block
the mount command.

I used the runlevel editor in Yast/system to disable the jexec service and mount (and automount) now work.

jexec is a service that “Supports the direct execution of binary scripts”

If I attempt to re-enable jexec in the runlevel editor, it fails

I suppose some java stuff wont work now.

It was suggested to remove the binfmt_misc lines in /etc/modprobe.conf, but I dont know what that might do.


I disabled the java service, but still there’s no sign (after rebooting) of a cd in the konqueror “My computer” window, dolphin, etc. I put the ‘device notifier’ on my taskbar (it lists things like usb sticks, external HD’s). The cd doesn’t appear.

However, I can play the cd w/ xmms (after telling it to use the IDE cable since emachines doesn’t give cd audio cables). I think this was the case before turning off java.

So I don’t quite know what’s supposed to happen in kde when you insert a cd. I vaguely remember a window, similar to Windoze, coming up and asking what action to take.

The saga continues.


I am having the same problem. I can mount dvd’s but cd’s do not show up. If I start KsCD then it shows the cd but no other applications know about it. I did not see the jexec so I can not disable it the way shown. I will keep researching though as I hate not being able to play my music. It mounts my iPod as well. I know back in the days of KDE 3.5 that you could set it up to mount the cd’s to the desktop. I did have an install with OpenSUSE 11.1 with KDE 3.5 but I did not try the cd’s then so not sure if they were working or not. I am running the 64 bit version as well.

There is a bug in openSUSE-11.1 (which I believe appeared/was-introduced only after the RC1 release) messing up permissions for cd/dvd drives.

The work around is to add your regular user to group “disk” and group “cdrom”.

This can be done by:

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”. Don’t forget after exiting YaST, you need to restart.

If that does not work, there are more suggestions here to work around this temporary problem Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change

I was able to get K3b working by just doing what some one else suggested and that was logging in as root and launching the application. When you logged back in as yourself this would fix that problem and it did fix it but the other applications will still not read the cd’s. Hopefully OpenSUSE will have a fix for this soon.


I already added myself to disk and cdrom groups, and I can indeed see cd’s in k3b. However, cd’s don’t show up in kde apps like konqueror (sysinfo:/), krusader, or the new device notifier. What about them?

Not wanting to give my user login raw hard disk permissions through group disk, I took the probably dumb step of giving my user login group cdrom permission, then changing /dev/sr0 and /dev/sr1 from group disk to group cdrom.

After logging out and back in it seems to be working, but I wonder what else I might have broken by changing the /dev group ownership to cdrom?

This is an openSUSE-11.1-DVD-x86_64.iso install DVD with KDE 3.5.

Of course I still experience “hald-addon-stor” process bugs where it unexpectedly/randomly hangs in an uninterruptable state waiting on a block I/O transfer (these HAL hangs have been a problem for me on my main computer since 10.2, but not on other older 32 bit machine). It makes my Linux experience reminiscent of Windows, because I have to reboot to burn each and every DVD or CD (otherwise I usually make coasters) and reboot just to read them when they suddenly becomes unavailable (just what I needed, a taste of good old Windows reboot in Linux – NOT!!!). I have found Gnome System Monitor 2.24.1 is very informative about these HAL details (if it starts). It might also be useful for checking other problems.

I have the same problem and also the same problem with the usb memorys , this caind of thing should happen with a distro like this.

really mad :@

I was having this same issue with both 32 and 64bit versions of 11.1 Thanks oldcpu, your solution worked for me.

This problem comes in i586 as well as X86-64 base SUSE 11.1. User is not able to mount DVD/CD and USB. Further user can not browse the User Home Directory from Gnome or KDE Desktop.

Solution is very simple , just disable the “jexec” service which is used to supports the direct execution of binary format.

The above issue might will come due to removal of OpenJDK , jexec is creating some conflicts.

Generally users are installing more stable and reliable SUN JDK for web services and java application.

Further ensure to assign the UID user and group (both) need to be in range of 1000 to 10000.
Yast - Security & Users - Local Security - User Addition - OK

Yast - Security & Users - User Management - Group ( Crete Group with UID > 1000 and assign as secondary group - this is optional )

So do this and enjoy reliable and sure-fast SUSE 11.1

With all best luck to SUSE Team and it’s community.


Am close to giving up on Opensuse have checked this suggestion out and find that jexec is not listed so canot disable.
I have two CD devices and one now works but the second does not and if I put a disk in I get the error message:-

DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus).

I have all the latest patches installed so I conclude I have another bug. If anybody can help please advise.


Please fallow the second solution --regarding User ID and Group ID of the concern user must be with in 1000 to 10000.

Further also ensure to install at least JRE and specify proper path in /etc/profile for JAVA_HOME.

Also confirm java/javac runs from your shell scripts.

Hi and many thanks. My ID was already 1000. I have changed the Users ID to 1500 to try it.

Do not understand about Java. I had assumed it was installed from outset but it appears not. How can I check and if not installed why and how can java cause this problem.

Any suggestions as to which version of JRE to install?


Oh I forgot to mention my system is 32 bit so perhaps my problem has different cause.

This problem comes in i586 as well as X86-64 base SUSE 11.1. User is not able to mount DVD/CD and USB. Further user can not browse the User Home Directory from Gnome or KDE Desktop.

Solution is very simple , just disable the “jexec” service which is used to supports the direct execution of binary format.:slight_smile:

i have had installed opensuse 11.1 with gnome 2.26 build with susestudio and i got the same problems. i am also trying what was suggested here and it didnt work. when i run dmesg i get the following:

usb 3-2.1: new high speed USB device using ehci_hcd and address 3
usb 3-2.1: configuration #1 chosen from 1 choice
usb 3-2.1: New USB device found, idVendor=0325, idProduct=ac02
usb 3-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 3-2.1: Product: ATV
usb 3-2.1: Manufacturer: OCZ Technology
usb 3-2.1: SerialNumber: AA04012700137246
Initializing USB Mass Storage driver...
scsi8 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
scsi 8:0:0:0: Direct-Access     OCZ      ATV              1100 PQ: 0 ANSI: 0 CCS
sd 8:0:0:0: [sdc] 7831552 512-byte hardware sectors: (4.00 GB/3.73 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 43 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
sd 8:0:0:0: [sdc] 7831552 512-byte hardware sectors: (4.00 GB/3.73 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 43 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1
sd 8:0:0:0: [sdc] Attached SCSI removable disk
sd 8:0:0:0: Attached scsi generic sg4 type 0
usb-storage: device scan complete

but no device icon shows up in gnome. also i looked in gnome-setting and checked whether the gconf options are set correctly. no i have not installed the service jexec whatever this is and i did check the autorun serices.

scince problem also shows up in gnome, i think maybe this is more general problem



hello sorry to bring up an old topic but i think it has a lot to do with my problem.

First of all i have to say that i am a really inexperienced user in linux.

The problem has as follows. When i insert a cd dolphin doesn’t pop up in order to mount the cd. I have tried everything that i found in this topic.
I changed the user id from 1000 to a value between 1000 and 10000. I tried to delete this jexec file but i just can’t find it. I looked everywhere in this init.d directory but there wasn’t anything there to be found, through yast i could also not find this jexec.I even unistalled jdk and put an older version in case jdk 1.6 wasn’t stable. I only have problems with the dvd rom drive. External hard drives i can mount them without any problem.

my stats are:

Linux i686

openSUSE 11.2 (i586)
KDE: 4.3.1 (KDE 4.3.1) "release 6

G96 [GeForce 9600M GT]

Any suggestions are welcome but please keep in mind that i do not know a lot :frowning:

Is dolphin supposed to popup? On my KDE4 I do not have dolphin popup but rather on the bar on the bottom of the page, I get sort of an inverted menu appear briefly (originating from an icon that has a sort of monitor, with a plug on the screen and a CD sitting in the top). In that menu I can select dolphin if I desire.

Here are a couple of illustrations. This one:](

and then this one:](

If that menu is not appearing, then its beyond my ability to help, but I though it worth checking to see if this is nominal behaviour that you do not recognize.