CDROM wont work all of a sudden

I am using SUSE 11 with KDE. I was able to play cds at one point but not any longer. I have rebooted the machine and even tried the command mount -t iso9660 -o ro /dev/cdrom /media/cdrom which gets me the reply of: mount: mount point /media/cdrom does not exist. I looked in the hardware profiles and both of my drives show up but neither is usable anymore. Any help would be great, thanks!

not sure if this helps solve anything but i was just looking through my files under /dev there is a cdrom, cdrom1 cdrom2, cdrw1, cdrw2, dvd2, dvdrw1, and dvdrw2. I only have one cdrom and one dvdrw. The other odd thing is that all of those files appear to be shortcuts indicated by a small black arrow in the lower left portion of the file

Maybe bring out some computer magazines and show the drives some pictures of modern models while remarking how cheap new drives are? :wink:

Seriously though, maybe check if the cabling has come loose or something?

BTW you will not be able to mount audio CDs, they are just to be played, not mounted like data CDs. Also with automounting, the mount point will not exist already. You could try something like this with a data CD:

mount -o ro -t iso9660 /dev/sr0 /mnt

assuming that it’s the first drive and that /mnt exists (should in standard system).

I fixed a similar problem just by starting KsCD and I have no idea why that worked. But, looking around for an answer, I saw that suse is mounting these drives as sata, hence sr0 and sr1 etc. Someone fixed the problem by booting with the switch atapicd. YMMV. I won’t try that until the CD stops working again.