cdrom problem on new install


i just did a new install to a not-new iBook g4.
i’ve got a little experience with linux but it’s been a few years and i’m beginning to notice things have changed here and there.

anyways, i am confused out my mind about where my cd/dvd drive went.i did some reading and it seems i’m not the first. Here’s what i’ve tried / what happens:

  1. system info and device notifier know nothing.
    1a) they also “know nothing” about the network, and it seems to work ok, so maybe they’re poorly informed?
  2. however, ‘eject’ works just fine
  3. ls -l /dev/sr0 produces “no such file or directory” :confused:
  4. kscd crashes before it even loads
  5. k3b used to say i am missing a drive; after adding user to disk and cdrom groups, this went away (other 4 remain)

i referenced Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change
and have tried:

  1. adding users to cdrom and disk --some improvement
    2)create /etc/udev/rules.d/99-my.rules file with the following entry : KERNEL==”sr*[0-9]“, GROUP=”cdrom”, MODE=”0660″ and then reboot --no visible effect
    3)Patch /usr/share/PolicyKit/policy/org.freedesktop.hal.device-access.policy --no visible effect
    4)reboot at every in-between

What bugs me the most is, what/why/where’s /dev/sr0? how come /dev/hdc doesn’t mount anywhere? What is going on here?

And this is what my fstab looks like, although to be honest i’m afraid to mess with it:
cat /etc/fstab
/dev/disk/by-id/ata-Hitachi_IC25N060ATMR04-0_MRG326K3GDDK8H-part3 swap swap defaults 0 0
/dev/disk/by-id/ata-Hitachi_IC25N060ATMR04-0_MRG326K3GDDK8H-part4 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-Hitachi_IC25N060ATMR04-0_MRG326K3GDDK8H-part5 /home ext3 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

somebody hepl?

the standard place where you find the dvd player in opensuse for me has always been it gets mounted automatically to


CD-ROM/DVD drives no longer require an fstab entry. They are normally handled via udev/hal. You don’t say which version of openSUSE you’re using, or which desktop. If using KDE4 for example, you won’t see any notification (unless you’ve installed a widget to do so) when you insert a data CD/DVD. The Dolphin file manager will show a device icon in the left-hand panel. You can click on this, to mount the file system contained. It will then mount within /media (as mentioned by previous poster).

However, this does concern me

  1. ls -l /dev/sr0 produces "no such file or directory

I would have thought you would get something like this returned

dean@linux:~> ls -l /dev/sr0
brw-rw----+ 1 root disk 11, 0 2009-08-25 07:54 /dev/sr0

Makes me wonder if you have a driver issue…

What does this command return?

/usr/sbin/hwinfo --cdrom

I could be on the wrong track here, but after quick google (nearly bed time for me here in NZ), I found this Ubuntu thread.

Try issuing this command from a terminal as root

modprobe ide-scsi

Then do

ls -l /dev/sr0

If all is well, try inserting a data CD and see how that goes.

hi everyone!

deano_ferrari: I am using opensuse 11.1 (ppc)/KDE 4.1.3 “release 4.9”.

i did:
1)modprobe ide-scsi
i could swear it took an hour to kick in…or else after i read dmesg. weird.

1)ls -l /dev/sr0
brw-rw---- 1 root disk 11, 0 2009-08-24 08:38 /dev/sr0 :smile:
2) /usr/bin/hwinfo --cdrom
bash: /usr/bin/hwinfo: No such file or directory
3) eject no longer works - user or root. i now have a disk stuck in the drive - lets see if it comes out at reboot lol!

  1. >Dolphin file manager will show a device icon in the left-hand panel
    negative, i only have: home, network, root, trash
    >…when you insert a data CD/DVD
    no luck with: audio cd, data cd, movie dvd, USB thumb drive. :frowning:

So the good news is, now i have a /dev/sr0
dmesg says:
<code>hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
sr0: scsi3-mmc drive: 8x/40x writer xa/form2 cdda tray
sr 0:0:0:1: Attached scsi CD-ROM sr0 </code>

I have no idea what to do next.

Thanks for your help.


ls -l /media/dvd
ls: cannot access /media/dvd: No such file or directory


the /dev/sr0 was a false alarm, it was a iso image i had on the USB thumb drive.

no usb - no /dev/sr0

back to square one.

You typed

  1. /usr/bin/hwinfo --cdrom
    bash: /usr/bin/hwinfo: No such file or directory

The correct path and command was

/usr/sbin/hwinfo --cdrom

Try again with the following commands

modprobe ide-scsi (as root)
ls -l /dev/sr0

Report output of last command. We’ll go from there.