cdda2wav causes kernel panic

Hey guys,
I’ve been encountering some problems lately. Seems like every time I try to use cdda2wav (through Grip, but also happens when I run it from command line) to rip the last audio track on a music CD which also has data on it - the kernel panics, with the trace listing the cdda2wav process as culprit. If I try and use cdparanoia instead of cdda2wav, this doesn’t happen but it also won’t start ripping - it just skips through the tracks but doesn’t produce output, while cdda2wav produces the desired output, but sadly crashes horribly after. Grip also shows the drive going on ripping after the progress bar is entirely filled. After reboot, I can find the entire last track where it’s supposed to be, but having to force a reboot in order to rip just one CD seems a little off balance IMO.
(FYI, the tested CDs were “Wheatus” by Wheatus and “Lights And Sounds” by Yellowcard, I think both “featuring” some kind of copy protection - but I have ripped them both successfully in the past and even if not, they weren’t supposed to crash my system if I tried.)
I’ve recently upgraded my RAM but I don’t think that’s the problem; Memtest86+ doesn’t complain and I’ve reverted to my old RAM for testing purposes: they also kernel panic.
My problem can’t be too old, either my CD drive has gone to rot or there was some bad software update lately.
Anyone else having this problem? I know you’d like to have the console output from the panic, but I don’t know how to do this right now.
Oh yeah, I forgot, I use openSuSE 11.1 with The problem also occurs on