Cd Rom missing after upgrade 11.4 to Tumbleweed

I upgraded 11.4 to Tumbleweed lately. There is one problem - I cannot see the Cd Rom Drive. It is not in Yast - Hardware info, the command hwinfo shows:

block.1: block modules
----- exec: "/sbin/modprobe ide-cd_mod " -----
FATAL: Module ide_cd_mod not found.
----- return code: ? -----
----- exec: "/sbin/modprobe ide-disk " -----
FATAL: Module ide_disk not found.
----- return code: ? -----
----- exec: "/sbin/modprobe sd_mod " -----
----- return code: ? -----
>> block.2: sysfs drivers
>> block.3: cdrom
----- /proc/sys/dev/cdrom/info -----
drive name:
drive speed:
drive # of slots:
Can close tray:
Can open tray:
Can lock tray:
Can change speed:
Can select disk:
Can read multisession:
Can read MCN:
Reports media changed:
Can play audio:
Can write CD-R:
Can write CD-RW:
Can read DVD:
Can write DVD-R:
Can write DVD-RAM:
Can read MRW:
Can write MRW:
Can write RAM:
----- /proc/sys/dev/cdrom/info end -----

I can see the CD Rom in Bios, when I put a bootable CD inside, it works - so there is no hardware problem at all. It looks that some modules are missing after upgrading kernel. I am not an expert, I would be grateful, if you could tell me, how to solve this problem - perhaps manually load required modules.
Thank you.

Post your repo info

zypper lr -d

I am sorry, it is my home computer and I am in the office now, as far as I can remember, there are only repositories from Portal:Tumbleweed:

Index of /repositories/openSUSE:/Tumbleweed/standard
Index of /distribution/openSUSE-current/repo/oss
Index of /distribution/openSUSE-current/repo/non-oss
Index of /update/openSUSE-current

Those are correct
I’m not aware of any issues with the recent updates in TW
I don’t have any 11.4 installs > TW though - only 12.1

See if you have the option to switch between systemV and systemd
openSUSE News

It’s F5 at boot menu
Try systemV if it has the option

I tried to switch between sytemV and systemd - the same problem.

Open a terminal and post result of

su -
zypper ve

I’ll do it in the evening. Do you think that there is a problem with dependecies?

Probably not.
More likely a glitch in the upgrade process.

Did you do 11.4 > 12.1 > TWeed? (Which is the method I would have taken)

I followed the instructions:

Portal:Tumbleweed - openSUSE

There was only one thing that I had not done - allowing vendor change:

“You will need to allow vendor change from Tumbleweed. This is done by creating a file named Tumbleweed.conf in the /etc/zypp/vendors.d/ directory with the following content:…”

I am home - zypper ve - dependencies are OK.

Good

The vendor change should not really matter with those 4 repos if you ran zypper dup

I still feel (and this is just my 2c) that I would have moved to 12.1 then to TW
Or even better, a clean install and > TW

Did you try:

su -
modprobe cdrom sr_mod

Yes, nothing happened when I entered modprobe cdrom sr_mod.
When I tried lsmod, there is:
cdrom 46705 1 sr_mod

hwinfo --cdrom - nothing

It looks like a wrong module for cdrom. It is not important, I do not use CDRom often. The easiest way it would be to reinstall 12.1 from DVD.
Thank you for your help.

FYI
I’ve done 4 separate 12.1 installs this week followed by ‘dup’ > TWeed, with no issues.

Clean install or upgrade?

Clean install 12.1
Update
Then ‘dup’ to TW

I decided to wait for a while. with a new instalation. I made an install DVD, when I started the DVD and entered “Rescue” menu, command hwinfo --cdrom showed me all the information about the CDRom. So it is like a wrong driver in Windows. Clean installation is like reinstalling Windows because of a wrong driver. If I wanted to change the CRrom drive, I would be in the same situation. There must be a solution.

I don’t think drivers are anything to do with it, because there just are no drivers (Well not in the windows sense of things).

It’s more likely some crud in the upgrade

As far as I know there are kernel modules that are loaded at start. I suppose that my opensuse loads wrong cdrom module at start and that is the reason, why I cannot see cdrom. Suppose that I will buy a new cdrom drive to replace working - but old one. What I should do? Reinstall opensuse? I hope not. Anyway, thank you for your help. I am only curious.

I added new Optical drives many times
It’s just plug and play (At least it is on a working system)

I have a service computer in my office. There is instalation opensuse 12.1 too. I replaced the cdrom drive and you are right - opensuse can see the new cdrom drive, no problem.
When you install opensuse, it scans all hardware. I suppose that after that it load modules that are needed, write configuration files and compiles kernel. I would like to know, if it is possible to do it on running system - rescan of hardware.
At home I could remove cdrom module from kernel (rmmod), but after restart there is wrong cdrom module again. I am sorry for asking stupid questions, but I am only “linux user”.