CD/DVD is mounted but files are not readable

Hello everyone,
I have a little problem using CDs or DVDs. If I put a disc in my DVD-Recorder it is mounted and the content of the disc is shown in dolphin (or any other programm for that matter). The names and attributes (size, date etc) of the folders and files are all correctly shown - except it is a multisession-disc, then there are only files of one of the sessions (probably the first) shown. The permissions say that the files are readable (user is my useraccount and group is “root”).
However, if I try to open a file on the disc, the program (for example sm-player if it is a video) freezes or displays a message that the file is corrupted (for example open office if it is a textfile).
Trying to copy a file from the disc to the harddrive results in an error that the file is not readable, but there is a file created on the harddrive - it has the correct name but the size is 0B.
Burning a disc with k3b creates also an error, although the disc is correctly recognized - but as soon as the burning should start an error occurs.
I’m pretty sure that it is not an hardware-issue, since this DVD-Drive has worked fine under openSUSE11.1-32bit and it still works if I put a bootable disc in. There is no problem runnig a live-CD and I had no problems with the drive when I installed the very same system that I’m working with from a disc.
Logging in as root doesn’t change a thing.

I’m currently using:
OS: Linux x86_64
System: openSUSE 11.2 (x86_64)
KDE: 4.3.5 (KDE 4.3.5) “release 0”
The drive is a DVD+R DL Recorder (IDE) which is around 3 years old.

I tried to search if this problem was solved before, but all I found were problems where the disc-drive wouldn’t mount at all … so please, if anyone knows a solution or at least a place where I can found one - I really have no idea what to do about this.

Try checking/changing the cables, anyway, even if it boots ok (when it’s cold, for instance).

What you describe is typical of hardware/media failure. I presume you already tried other disks or media, with the same results?

Note that 3 years is about the useful life of a recorder, few last more than that.

My DVD drive did exactly the same thing two weeks ago. I also couldn’t read or copy files but could boot a live CD. I replaced the drive with a new one and everything started working again.

OK, I’m gonna try another drive then.
Thanks for the answers.