CD drive problem in kde4.1

I don’t know where to begin looking to solve this one. Similar problems are mentioned in other threads but either don’t apply or solve the problem. One thread said to make sure autofs was running. It wasn’t, so I started it, but that didn’t work.

I have opensuse 11 with kde4.1 installed. I don’t remember when exactly, but it must have been after an update. Most of my apps can no longer see my CD drive or my DVD drive.

I can insert an audio CD and none of the following see it:
Dolphin, Konqueror, Amarok, KScd, or VLC media player. hmmmm… maybe the drives “disappeared” when I installed VLC. That was the last thing I installed. However, k3b can see both drives and what I did to play the cd was rip it and play the songs from the hard drive through amarok. k3b sees these drives as /dev/sr0 and /dev/sr1 and by their actual hardware names (i.e. Sony DVD).

Is this a 4.1 problem or something else?

If I insert a data cd, Dolphin sees it as /media/cdrom but putting an audio cd immediately into the same drive makes the drive “disappear.” Also, I cannot eject the data cd by pushing the drive button while Dolphin is open. I get an error box that the device is locked by another program. I thought Dolphin should be able to eject the cd itself but it can’t.

I can work around this, but with your help, I won’t have to.

Is this a 4.1 problem or something else?

Probably the easy way to establish that is to login to kde3. You should have it installed too or at least one other option, seeing kde4 has been such a problem for many.

Thanks. I’ll give that a try. Still, I’d like it to work in 4.1.

Same problem here.

The devices plugged in widget does nothing at all with an audio CD, and most apps just complain it isn’t there.

same here! Nothing… DVD’s are not a problem. What is going on?!

i have the same problem with two ide burners. (one is a cd burner the other is a dvd burner).

i noticed autofs/amount was disabled so i re-enabled it (even though i did not disable it) but it didn’t help at all…

kde4-k3b is the only app that will see my audiocd. i cannot mount (load) it though as the device menu is empty. although in lancelot (the new kde menu plasmoid) the disc is listed as unmounted but when i click on it it says: “The requested device can not be accessed.”

i’m running os11 w/ kde 4.1.68 but it has been this way for a while.

i wonder if this is a kde problem or perhaps a kernel problem. i can’t test it on kde3 or gnome cuz i only run kde4.

I have the same 2-drive setup. I just got over a problem but I’m not sure what did it. I tried as many things as I could find in the forum.

The basic problem, this time, was that I did not have permission to write to a disk, so even after both drives were recognized, I could still not burn a cd.

I started by trying to change the drive permissions via Dolphin, then kdesu Dolphin, and finally kdesu Konqueror. The last one let me change the permission so “others” could read and write to the drives. It didn’t work. Next, I tried adding myself to the group “disk.” That didn’t work.

I tried opening amarok. It didn’t even see the drives. Finally, I opened lowly old KsCD. It played CD’s in both drives. After that, I was able to burn a CD in k3b.

I’m running 11.0 and kde 4.1 and my packages are up to date. I don’t want to go through this again to burn a CD, since I don’t know which thing actually solved the problem.

i’m with you. same kde 4.1.68 (although i don’t know if you’re using kde 4.1.2 or 4.1.68) setup in os11.0.

some of the first things i tried were all the methods to change drive permissions that you’ve tried but that didn’t help either.
i did add my user to the ‘disk’ group too a while back but no such luck there either.

i never liked kscd but installed it (for kde4) a few days ago and it wouldn’t recognize the discs just like kde4-amarok.

so i’m not as fortunate as you are now…

I just opened KsCD to see where the options were and didn’t see any. But, to get it working, I think I had to do this:

start kscd
at the bottom right of the interface is a button “Extras”
click it
In the next box, click “Configure KsCD”
There is an option, with a drop down box, to select the CD device. When I first started kscd, this box was blank. But, clicking on the down arrow revealed my two drives and I selected one.
After that, things started to work.:beat-up: