CD can't eject using eject button

Right clicking on the desktop CD icon eventually ejects it. But it still can’t be ejected using the button.
What is wrong here?
Please help me,

Box: openSUSE 11.2 | GNOME 2.28.2 | Acer RS740DVF | AMD64 X2 5600+ | Radeon HD4670 | 3GB RAM

izaak86 wrote:
> What is wrong here?

there are several different things that may have happened:

-drive button stopped working
-drive motor failure
-drive gear train failure
-drive controller failure
-drive locked by software
-disk shattered, jamming drive
-computer/software power management cut power to the drive
-power or data leads became unplugged/shorted/loose

have you tried opening a terminal and entering this:

eject -T

if the drive is closed it should open, and if open it should close…
but, not all drives will accept that command

have you tried opening the bay with a paperclip? see:


Isn’t the preferred way using the software (e.g. right click and eject)?
The software way will look after sync and proper unmount and the like (not only for CDs, but for all removables).

Everythings ok now. Thanks all!


Do not simply remove disks from the drive after using them. Floppy disks, CDs, and DVDs must always be unmounted from the system first. Close all applications still accessing the medium, then right-click the icon for the medium and select Eject Volume or Unmount Volume from the menu. Then safely remove the floppy disk, CD, or DVD when the tray automatically opens.

Source: OpenSUSE 11.2 GNOME User Guide

izaak86 wrote:
> Everythings ok now. Thanks all!

can you tell us how you fixed it? please…


Well to be certain I didn’t do much actually, it just works correctly after i ejected it using the terminal and reboot.