Catfish on Leap 15.1 old dependencies

Trying to get my beloved catfish tool up and running but it is asking for python 3 and ruby 2 etc, which broke my system before.

Anyone knows how to get it installed without breaking the whole system?

Thank you very everyone trying to help ;-))

Dirk

https://software.opensuse.org/package/catfish?search_term=catfish