catalyst 13.1 legacy, stock opensuse 12.2, radeon HD 4250 - blank screen

I installed opensuse 12.2, stock (no updates) on a fresh partition and installed the catalyst 13.1 driver. It installed without any problems, even loads the fglrx module. I added the kernel boot param “nomodeset”.

Upon booting, the screen goes blank. The xorg.conf file looks OK, with the correct PCI bus ID (verified with lspci).

The card worked fine with previous opensuse versions and older catalyst drivers ( prior to 12.6). It works OK with open source radeon driver but certain feautures do not work (notably webGL based games/apps) which DO work with the catalyst driver.

The only signs of possible trouble are these in the system log -

Mar 4 19:19:51 linux-750e kernel: 21.287220] [fglrx] ATIF platform detected with notification ID: 0x81
Mar 4 19:19:51 linux-750e kernel: 21.392251] [fglrx] GART Table is not in FRAME_BUFFER range
Mar 4 19:19:51 linux-750e kernel: 21.392437] [fglrx] Could not enable MSI; System prevented initialization
Mar 4 19:19:51 linux-750e kernel: 21.397042] [fglrx] Firegl kernel thread PID: 1022
Mar 4 19:19:51 linux-750e kernel: 21.399941] [fglrx] Firegl kernel thread PID: 1025
Mar 4 19:19:51 linux-750e kernel: 21.403033] [fglrx] Firegl kernel thread PID: 1030
Mar 4 19:19:51 linux-750e kernel: 21.403159] [fglrx] IRQ 18 Enabled

The xorg log does not contain any ‘EE’ type msgs.


  • yast
    – /etc/sysconfig Editor



set to yes?

I tried this. ran mkinitrd, re-installed boot loader (grub2). No effect.

I feel it has something to do with radeon module in initrd.



the radeon driver should be blacklisted if the fglrx driver is
correctly installed, this is done via file /etc/modprobe.d/50-fglrx.conf
and its contents should be
blacklist radeon

how did you install the fglrx driver?

have you tried the driver from repo below?
Index of /mirror/amd-fglrx-legacy/openSUSE_12.2
(you do need the legacy driver)

if the above gives a negative result have you worked your way thru’
procedures given in

best of luck