capricious suse 11.2 - boot problems

hi, people,
i have installed suse 11.2-desktop and became problems by booting - suse behave itself very peculiar! sometimes boots it, sometimes not. interesting is - in failsafe mode boots it splendid and my other os`s (winxp and puppylinux) boot too. only in normal mode is there a problem. has anybody some ideas?

When it does not boot properly, can you get to a text login ? ( via <ctrl><alt><f2> ? If so, save the dmesg with something like:
dmesg > failed-dmesg.txt
and make a copy of the appropriate log files such as /var/log/message and /var/log/Xorg.0.log and see if there is any indication in there as to why it failed when it failed.

hi, oldcpu, thank you, i`ll try it.

I have any failure found, but the problem is still here. Interesting is – when I have for the first booting a dvd in a cd-rom, then boots suse properly. it`s no matter, what a dvd is it.:’(

failsafe boot is the same as a regular boot, with the only difference being in failsafe there are a series of boot codes applied that are not applied in a regular boot.

If you reboot, and look the grub selection menu (where you choose a regular boot or failsafe) and if you select fail safe, you will see many extra boot codes in the options line.

Write those down.

Then try them one by one in the regular boot, until you figure out which one enables your regular boot (and hence your failsafe) to boot properly.

Once you know that, then you can investigate the problem further.

hi, oldcpu and thank you,
i tried extra boot codes one by one in the regular boot with any results. No special one code helps. Now I have this: kernel command line: root=/dev/disk/by-id/ata-SAMSUNG_HD501LJ_S0MUJ1DPA06713-part2 repair=1 resume=/dev/disk/by-id/ata-SAMSUNG_SP2504C_S09QJ1OL712055-part6 splash=silent quiet apm=off noresume edd=off powersaved=off nohz=off highres=off vga=0x31a
with such configuration boots suse, bu I still don’t know why.:\

Are all those codes needed? If you remove apm-off, or edd=off or powersaved=off or nohz=off or highres=off does it still boot?

i did not probe it in combinations. i exclude code for x11 and “processor.max_cstate=1”, cose suse write:"unknown boot option - ignoring. but the only one code of this group does not help.

I think I did not explain myself well enough? The idea is to determine PRECISELY what boot code is needed to boot, so that you can understand better the problem. In my opinion, if you do not narrow down the boot code, it will be much more difficult.

ok, oldcpu, you are absolutely right. i`ll try it in all combinations. thank you for answers.

now i can boot only with “highres=off”. curiously, earlier it didn`t work. but by booting write suse:
“doing fast boot
FATAL: module mbcache not found
creating divice node with udev”:\

I do not know what “highres=off” does. I recommend you write a bug report.

i’ll try. one more peculiar thing - if cd-rom goes for a harddisk in booting order, then doesn’t boot suse