Can't wake up Atheros AR5001X+

I just fitted a Netgear WG311T, which comes highly recommended as an ideal Linux wireless card. It apparently works “out of the box”. Well not for me. YAST’s Network Settings recognises it but won’t let me configure it:

Atheros AR5001X+ Wireless Network Adapter (Not connected)
BusID : 0000:00:08.0

Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

dmesg gives:

ath5k_pci 0000:00:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
ath5k_pci 0000:00:08.0: registered as ‘phy0’
ath5k phy0: failed to wakeup the MAC Chip
ath5k_pci 0000:00:08.0: PCI INT A disabled
ath5k_pci: probe of 0000:00:08.0 failed with error -5

Looks pretty serious to me. I’ve Googled around but I lack the experience to make sense of most of what I’ve found. I’ve tried various published solutions but none work for me. I’ve installed madwifi and then removed it again as it makes no difference either way.

Can anyone help?

The system is 64-bit AMD Sempron and I’m running SUSE 11.1.

Thanks in advance.

Post the complete content of the file /var/log/boot.msg as an attachment or using a “pastebin”-service of you choice and link it here.

Thanks for the quick response. The file is over 700 lines long so I opened a pastebin:

Contents of /var/log/boot.msg

The relevant part seems to start at about line 509.

The system is a Biostar K8VBK-S7, about 4 years old, with VIA K8M800 and VT8237R chipsets.


<6>ath_pci: 0.9.4
<6>ath_pci 0000:00:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
<3>wifi%d: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)
<6>ath_pci 0000:00:08.0: PCI INT A disabled

<6>FDC 0 is a post-1991 82077
<6>ath5k_pci 0000:00:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
<6>ath5k_pci 0000:00:08.0: registered as 'phy0'
<3>ath5k phy0: failed to wakeup the MAC Chip
<6>ath5k_pci 0000:00:08.0: PCI INT A disabled
<4>ath5k_pci: probe of 0000:00:08.0 failed with error -5

Twio drivers for one device at the same time is no good idea.

Remove all madwifi packages and reboot.

If the problem persist,

a) post the new boot.msg

b) use this script

Getting Your Wireless to Work - openSUSE Forums

I did as suggested; here is the new boot.log:

Boot log 2

and the collectNWData script simply does this, without generating a collectNWData.txt output file:

— Which type of your network connection should be tested?
— (1) Wired connection
— (2) Wireless connection (WLAN)
— Please answer with 1-2:2

— What’s the type of networktopology?
— (1) WLAN access point <—> LinuxClient
— (2) WLAN HW router <—> LinuxClient
— (3) WLAN access point <—> LinuxRouter <—> LinuxClient
— (4) WLAN HW router <—> LinuxRouter <—> LinuxClient
— Please answer with 1-4:2
— Analyzing system for common network configuration errors…
!!! CND0110E: For the selected connection type there was no active network interface found on your system
!!! CND0230W: IPV6 enabled
!!! CND0240E: knetworkmanager for network configuration enabled but network card configuration for eth0 detected
— Collecting networkconfiguration information …
— Go to Fehlermeldungen/Errormessages | collectNWData.sh Fehlermeldungen to get more detailed instructions about the error/warning messages and how to fix the problems
— If you still don’t have success then post the contents of file collectNWData.txt in your favorite Linux forum. For an alternative read Webseiten für Text- und Bilderuploads/Websites for text and image uploads | collectNWData.sh

As you are connected to the net via cable, first run a complete online update to get the latest kernel for 11.1 (2.6.27.21).

There seem to be some serious maybe BIOS related issues, you also seem to have a problem with at least one of you USB slots.

<6>usb usb5: SerialNumber: 0000:00:10.4
<3>usb 1-1.4: device not accepting address 3, error -71
<3>hub 1-1:1.0: cannot disable port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
<3>hub 1-1:1.0: cannot disable port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
<3>hub 1-1:1.0: cannot disable port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: cannot reset port 4 (err = -71)
<3>hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
<3>hub 1-1:1.0: cannot disable port 4 (err = -71)
<3>hub 1-1:1.0: unable to enumerate USB device on port 4
<3>hub 1-1:1.0: cannot disable port 4 (err = -71)
<3>hub 1-1:1.0: hub_port_status failed (err = -71)

Are you 100% sure there are no hardware defects with that machine?

After the upgrade repeat steps from your last posting.

The NWeliza script always generates an output file in the same directory, be sure to check thoroughly.

Maybe some special boot options casn help, but first a recent base should be provided (=> online update).

Once again:

boot.msg

The collectNWData.sh script really does produce no output file. Looks like it gives up before reaching that point.

lspci reports the card:

00:08.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)

I already have the latest kernel and no updates are available. The USB error messages were coming from an external hub, which works fine but I’ve disconnected it for this test. Other hardware faults are probably unrelated but here goes anyway:

On a restart the DVI monitor fails to lock onto the signal from the graphics card so the system boots without any display. It’s always done this whatever operating system is used, on two different motherboards. Power-down is the only way to restart it; a real nuisance in Windows but fortunately not in Linux.

I recently bought a large SATA drive but the BIOS can’t see it.

The system started hanging regularly with the cursor frozen. Usually when booting from cold but at other times too. Though loath to spend the money I was going to replace the machine, but it mostly stopped doing it and has been working fine since.

I found a reference to what looks like the same problem on this blog; also on this madwifi ticket showing exactly the same messages I’m getting in boot.msg. That was a year ago and for a different Atheros device, but it’s not clear to me if it was ever resolved.

One other thing; I have a Windows box lying around that I could try the card in to verify it’s not faulty. Do you think that would be helpful?

I really appreciate the effort you’re putting into helping me sort this out.

Well, be honest my friend, you have it now after the update you obviously made, the boot.msg showed 2.6.27.7.9 before and now it shows 2.6.27.21.

In that case it might be only a coincidence with the same error, I have something else in mind which I experienced with this card on another distro and was BIOS-related (ACPI, however on a laptop and teh bootlog gave direct instructions on boot parameters to try, whcih unfortunately is missing here), the card mentioned in your reference was known for lots of trouble one year ago (AR5007EG Chip) and one of the latest chipsets supported by ath5k.

Your card fails with ath_pci and ath5k, so it’s more likely there is another cause (faulty ACPI/IRQ- or BIOS-problems).

Yes, that’s a good idea, putting the card into another box and also trying another pci-slot in your linux box are worth a shot.

You have a “non-standard” problem (mostly it’s wrong/no driver and/or user error on configuration), so this is something more interesting worth investing time (and certainly learning something new for myself).

If the card works in another box and does not work in your linux box even when putting it into another PCI-slot, the next step will be trying several ACPI/IRQ-related boot parameters.

Shouldn’t happen >:( . Could you do me a favor and run the latest version I uploaded right now in a command window with debugging enabled

collectNWData.sh -d

and send the screen output to me (eMail sent per PM)

My only other non-laptop computer is an (even) older model and I don’t have a 32-bit SUSE, so I installed Kubuntu 8.04.2 on it (with no LAN cable connected). Immediately after the first boot it saw all the local access points with no trouble at all. So we now know (don’t we?) it’s a problem with my hardware/firmware, not the network card.

I’m going to try 64-bit Kubuntu on the problem machine. Or even Windows 2000; I guess if it’s a BIOS problem that will also have the same problem, but I wouldn’t know how to find any useful diagnostic output.

The computer is a Biostar iDEQ micro-ATX model with only one PCI slot, so no options there. Googling around it seems that others may have had problems with the Netgear card on VIA chipsetted motherboards, but no solutions relevant to Linux are offered. Biostar don’t list the machine any more so no upgrades available.

Assuming it’s a BIOS problem, what kind of things should I be looking for?

It is very likely that -as the problem seems to be BIOS-related- you will get similar problems, especially with older distros (although you never know, what happens, ACPI-stuff is nasty).

If it is a hardware problem on your machine (i.e. bad PCI-slot) you will certainly have this problem with every distro (trying other slots on your problem machine is something you should also do, as I already told you).

There are quite a few IRQ/ACPI-related boot parameters

SDB:Kernel Parameters for ACPI/APIC - openSUSE

which can be added temporarily at the bootscreen (see the Boot Options line).

Try them and see if somethng changes, other useful parameters might by

irqpoll

pci=routeirq

If one )or a comnination) of these parameters work, read the linked article on how to make this permanent.

Start with acpi=off or acpi=force.

Now I didn’t expect this:

  1. After seeing the card work on the old 32-bit machine I moved it back to the Biostar. No change; the same messages as before.

  2. I disconnected my disks, fitted a spare hard drive and installed Kubuntu (kubuntu-kde4-8.04.1-desktop-amd64). To my surprise the wireless fired up right away, as it had on the old 32-bitter.

  3. “OK”, I thought, “it must be something in the SUSE boot sequence”. So I reconnected my drives and booted up to write this message. To my amazement the wireless network worked fine, just as it had on Kubuntu. The relevant lines of boot.msg now read

<6>ath5k_pci 0000:00:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
<6>ath5k_pci 0000:00:08.0: registered as ‘phy0’
<7>phy0: Selected rate control algorithm ‘pid’
<6>ath5k phy0: Atheros AR2414 chip found (MAC: 0x79, PHY: 0x45)

Can you make any sense of all this?

No, not really, such strange things just happen now and then.

I expected some ACPI-related trouble (as I mentioned, I had another thread in another forum, interestingly dealing with the same problem and the same card but under … guess what Ubuntu), but there were clear messages indicating what to do (bootlog stated to try some of the parameters I mentioned above) which were missing here.

Connecting (new) hardware is always a little Voodoo, most common is “works in one slot, does not work in another”…