Can't view any video opensuse 11

Hi, I recently installed openSUSE 11 KDE 4 live CD and it’s great.

However, I am unable to view any videos, avi, divx, etc. The audio works fine, but i get little clips when I enlarge the video in VLC, and then it goes black. The videos don’t work at all in MPlayer.

All the codecs seem to be installed, so, I’m not sure what is the problem.

FYI, I’m running a Radeon 9550 using the fglrx driver and compiz fusion.

Thanks, any help would be greatly appreciated

It could be a number of things, … but one thing that openSUSE-11.0 users encounter is when they have their “special desktop effects” enabled, they have difficulties. Try changing your output video mode (in your video players) from “auto” (or from “xv” (xvideo)) to “x11”.

Alternatively you could disable your ‘special desktop effects’

Also ensure you have w32codec-all installed.

You are an ANIMAL!
I loved it!
I had the same challenges with my Kaffeine in Open Suse 11.00.
Then I noticed Desktop effects on = no Video player.

Now how do I get previews and thumbnails turned on?
In other words, I want the desktop icon of a .PDF file to show what it looks like and the icon of a .GIF file to show a small picture.

Also how can I have a different Desktop backgrownd in each “Pager” screen?

And where can I find SuSE 11.0 documentation??

BTW, you are doing a heck of a job here, congrats!


Reading our stickie is a good place to start to links to all sorts of information:
NEWBIES - Suse-11.0 Pre-installation – PLEASE READ - openSUSE Forums

if you go down far enough …
NEWBIES - Suse-11.0 – PLEASE READ - openSUSE Documuentation

Re: your other requests, i assume they are related to KDE4. I don’t use KDE4 (I’m an openSUSE-10.3 KDE-3.5.7 and openSUSE-11.0 KDE-3.5.9 user).

yep, i tried disabling compiz fusion, and changed the video output in vlc to x11, still no dice.

thanks for the reply tho

“No dice” while descriptive, is not very factual nor helpful. Can you post the errors you get when you run the player from a konsole, and try to open the app? Ensure you have x11 selected as your video output mode. Do this test with all your players.

There are no error messages, in VLC, when I try to play the video, I can hear the audio fine, but all I see is black for the video, and I’m currently not at my computer, so I can’t test with MPlayer or Kaffiene.

Thanks again

Hi, I had the same problem. In Kaffeine use different videodrivers in video options (in xine-engine properties). Some give a black screen, some a shaky picture, but for me with AVI files vidixfb driver worked best. Just try a few.
Hope it works for you…

I’m also a newbie and facing the same video problem…
As i tried to change to video output from auto to any of the listed possibilities, i got the following error:
Can’t init video driver ‘<choosen one>’ - trying ‘auto’.
Any suggestions?

try this:

mplayer -vo x11 filename

where filename is the URL or file you are trying to play