Can't use VPN after upgrading to 13.2

x86_64 version.

I use Astrill VPN. VPN for internet surfing is a necessity in China, as you may know, which is where I live.
I upgraded to openSUSE 13.2 yesterday, and found myself unable to use VPN. After a long support call with astrill which involved reinstalling the client, and switching to other ports, protocols, and numerous other servers, no progress was made.
The same vpn service and client work on numerous other devices: Android, Windows, and another openSUSE 13.1 laptop which I wisely haven’t upgraded yet.

I was really hoping this wasn’t a 13.2 problem,because that would leave me clueless as to a solution, but it really looks like it is, considering it started with the upgrade, and isn’t present on other devices.
Any clues where to begin troubleshooting? Thanks.

Here’s a ticket I submitted with Astrill that may contain some details of better use:

I recently upgrade my PC from openSUSE 13.1 to 13.2 x86_64 build.
After the upgrade, I found that, while I can connect using the 2.9.2 2016 build Astrill client software, I can not surf websites that are otherwise blocked in China using either Stealth or OpenVPN modes. Using OpenWeb, I can surf all websites.
This happens no matter what ports, protocols, or servers I use, if I can even connect when I change them.
It may also be worthy to note that while I cannot surf websites such as youtube and google using stealth/OpenVPN, I can ping them and get replies. I do not get ping replies when I am not connected via Astrill.
I tried installing a 2.9.3 beta version and got the same result. I’ve also reinstalled the original 2.9.2 client ( a few times), deleting the user config files each time, with no result.
I also tried a speed test ( while connected via OpenVPN mode, and while the speed test ran, The Astrill client did not show any data being passed via VPN. It was being bypassed, for some reason. Speedtest showed the data being transferred from here in Beijing, rather than remotely from near the VPN server. When I do the speed test using Open Web, it runs normally, transferring data from the overseas server.
Other devices on my network (Android, Windows, other Linux) function via VPN normally.
It seems the system in question is not recognizing OpenVPN / Stealth connections, but has no trouble recognizing OpenWeb connections.
Please help me troubleshoot this. I’m also seeking help via openSUSE, but haven’t gotten anything useful yet.

I was able to work around this issue by switching from “NetworkManager” to “Wicked Service” in Yast2. I’m quite curious as to why one would work, and the other wouldn’t. See the routing tables:

Networkmanager( doesn’t work):

dh-desktop:/home/davidh # route -n
 Kernel IP routing table
 Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    1024   0        0 eth0   U     0      0        0 eth0       UG    20     0        0 tun0   U     0      0        0 tun0 UGH   0      0        0 eth0

Wicked (works):

dh-desktop:/home/davidh # route -n
 Kernel IP routing table
 Destination     Gateway         Genmask         Flags Metric Ref    Use Iface       UG    0      0        0 tun0         UG    0      0        0 eth0         UG    1024   0        0 eth0   U     0      0        0 eth0       UG    0      0        0 tun0   U     0      0        0 tun0 UGH   0      0        0 eth0

Perhaps worth submitting a bug report then.

I already did. That’s where I got the idea to switch to Wicked Service.

I glad that you did. (You hadn’t mentioned it previously). This may help others who come searching. :slight_smile:

Another bug has been opened, so it’s a reproducible issue:

Apparently, openVPN isn’t addfing this route, or Network Manager isn’t keeping it: via dev tun0 
default via dev eth0  proto dhcp 

Thanks for reporting this.

Latest workaround from the bug report:

I see. On this host, it’s “tun0” and not “tap0”.

ip r

gets me the address of the gateway, so:

route add default gw tun0

gets Network Manager working with vpn.

There is an elegant workaround using the Network Manager GUI on comment #10 for 904511.

I also had a VPN issue after 13.1 to 13.2 upgrade.
I use Network Manager as opposed to WIcked (I couldn’t configure Wicked)
It might be worth checking that in YAST2 - [Network Settings - Routing] that ipv4 is assigned to the appropriate internet connection
This enabled VPN for me