Can't use updates. Problem with connection

I’ve got OS 11.3 and updates via yast dosen’t working. Provided repositories URL are correct. When I try to refresh package list (i.e. when lunching software managment) it’s returns me error Unable to connect to url …/repodata/repomd.xml
URL is correct. I was looking for solution on the web and I found some footprints but no one guid me to solve it. :frowning:

This issuse occure on 2 diffrent netwroks (diffrent ISP).
Network connection is established correct.

Any ideas?


Are you saying you can browse the net?

Open a terminal and type: su -
(hit enter)
type your password…

Type this: zypper up
(what happens)

If it fails, type this: zypper lr -d
Post result

Retrieving repository ‘openSUSE-11.3-Oss’ metadata ]
File ‘/repodata/repomd.xml’ not found on medium ‘

Networking is working. I can download files from Index of /distribution/11.3/repo/oss with wget, but I can’t find repodata there at all. I think problems started at Saturday.

Repo config is default (freshly installed 11.3), except DVD repo, which is disabled.

I think problems started at Saturday, but I am not sure. I installed 11.3 in the morning and everything seemed ok, however later I decided to change partition layout drastically and did reinstall. Problems with repos showed then.

Do this as su -

**zypper clean --all

zypper verify**


rpmdb --rebuilddb

Retrieving repository ‘Updates for openSUSE 11.3 11.3-1.82’ metadata [done]
Building repository ‘Updates for openSUSE 11.3 11.3-1.82’ cache [done]
Retrieving repository ‘openSUSE-11.3-Non-Oss’ metadata [done]
Building repository ‘openSUSE-11.3-Non-Oss’ cache [done]
Retrieving repository ‘openSUSE-11.3-Oss’ metadata ]
File ‘/repodata/repomd.xml’ not found on medium ''

Please post as requested result of:

zypper lr -d

# | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes     | Yes     |   99     | rpm-md |                       |
2 | openSUSE-11.3 11.3-1.82             | openSUSE-11.3 11.3-1.82             | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                         |
3 | repo-debug                          | openSUSE-11.3-Debug                 | No      | Yes     |   99     | NONE   |  |
4 | repo-non-oss                        | openSUSE-11.3-Non-Oss               | Yes     | Yes     |   99     | yast2  |    |
5 | repo-oss                            | openSUSE-11.3-Oss                   | Yes     | Yes     |   99     | rpm-md |        |
6 | repo-source                         | openSUSE-11.3-Source                | No      | Yes     |   99     | NONE   | |

Is the type for OSS repo correct?

Solved by removing and adding OSS repo. Now the type is yast2 and everything works. The question is why it had “rpm-md” type in the beginning?

Become su - in a terminal and do the following

zypper rr 5
zypper ar -f oss
zypper ref

accept key if requested

Has this helped

hi, i try to solve it by removing all repos, and add all again but it dosent help.
Now I even cant add any repo ;/
When I try to add repo via yast it’s return same error - Connection error.

How I can solve it ?