Can't use pppoe on 11.4

I installed 11.4 kde rc1.When I tried to setup pppoe in yast,it always said I should install linux-atm.
But how can I install it?I can’t connect to the internet so I can’t download the linux-atm.And without this package,I can’t use pppoe to connect to internet.
Any idea to solve this problem?

> I installed 11.4 kde rc1.

Do you mean that you are running the
or the i586 version? These are cut-down distributions intended to run on average desktop machines. If there is kernel supprted ethernet or wireless network hardware detected it will try to configure that to connect to the local network using DHCP. If your local network has a gateway to the Internet then this should also be automatically configured. Without DHCP you will need to configure the network interface using e.g. YaST. This should be done before trying to install to the hard drive, as the installation will attempt to connect to the openSuSE repositories so as to make the cpppomponents not on the Live CD available. For any other scenario you are advised to use the DVD installation process.

> I tried to setup pppoe … linux-atm

linux-atm is on the DVD. But are you sure you should be doing this? Live-CD implies an average desktop or laptop machine. Pppoe or pppoa and linux -atm are used for comms equipment like modems and DSL routers. The only likely scenario I can think of is that your computer has an ISDN interface and that your ISP is providing pppoe over ISDN and you do not have a hardware ISDN router/modem. This seems unusual, but if it is so you will need at least the DVD iso and maybe more. Also we would need to know in what part of the world you are located and probably who your ISP is, in order to be of more help.