Can't use framebuffer or vesa Xorg with two memory modules on M51se laptop

Hello to everyone, I would to find more info for resolving this old issue that is solved few years ago with other distributions like pclos, debian , ubuntu…
In few words I try to explain my problem.
I just installed opensuse 12 from network installation setup but with “no kms” option and after finishing I unable to boot with 2x2gb dual channel ram setup.
If I go to remove second bank of ram I able to run opensuse and all work perfectly (this distro is very impressive and solid, looks like for me)

This error may be depends to bug bios set reserved mem area and conflict whit graphics card memory reserved space…or similar thigs (unfortunately I not fully understand this problem to explain well to us)

I go to find a solution, look a logfile print this below:

2013-08-31T23:30:07.684472+02:00 linux kernel: 1.682289] ------------ cut here ]------------
2013-08-31T23:30:07.684474+02:00 linux kernel: 1.682293] WARNING: at /home/abuild/rpmbuild/BUILD/kernel-desktop-3.7.10/linux-3.7/arch/x86/mm/ioremap.c:171 __ioremap_caller+0x2ab/0x480()
2013-08-31T23:30:07.684476+02:00 linux kernel: 1.682295] Hardware name: M51SE
2013-08-31T23:30:07.684477+02:00 linux kernel: 1.682296] Info: mapping multiple BARs. Your kernel is fine.
2013-08-31T23:30:07.684479+02:00 linux kernel: 1.682297] Modules linked in:
2013-08-31T23:30:07.684485+02:00 linux kernel: 1.682301] Pid: 1, comm: swapper/0 Not tainted 3.7.10-1.1-desktop #1
2013-08-31T23:30:07.684487+02:00 linux kernel: 1.682303] Call Trace:
2013-08-31T23:30:07.684488+02:00 linux kernel: 1.682313] <c0205779>] try_stack_unwind+0x199/0x1b0
2013-08-31T23:30:07.684490+02:00 linux kernel: 1.682319] <c0204487>] dump_trace+0x47/0xf0
2013-08-31T23:30:07.684491+02:00 linux kernel: 1.682323] <c02057db>] show_trace_log_lvl+0x4b/0x60
2013-08-31T23:30:07.684493+02:00 linux kernel: 1.682326] <c0205808>] show_trace+0x18/0x20
2013-08-31T23:30:07.684494+02:00 linux kernel: 1.682330] <c06fbeeb>] dump_stack+0x6d/0x72
2013-08-31T23:30:07.684496+02:00 linux kernel: 1.682334] <c0238cb8>] warn_slowpath_common+0x78/0xb0
2013-08-31T23:30:07.684498+02:00 linux kernel: 1.682338] <c0238d83>] warn_slowpath_fmt+0x33/0x40
2013-08-31T23:30:07.684503+02:00 linux kernel: 1.682341] <c022e85b>] __ioremap_caller+0x2ab/0x480
2013-08-31T23:30:07.684506+02:00 linux kernel: 1.682345] <c022ea98>] ioremap_nocache+0x18/0x20
2013-08-31T23:30:07.684507+02:00 linux kernel: 1.682349] <c0ae4e1b>] vesafb_probe+0x61b/0x765
2013-08-31T23:30:07.684509+02:00 linux kernel: 1.682354] <c053a1b9>] platform_drv_probe+0x9/0x10
2013-08-31T23:30:07.684510+02:00 linux kernel: 1.682358] <c0538d64>] driver_probe_device+0x74/0x360
2013-08-31T23:30:07.684512+02:00 linux kernel: 1.682362] <c05390c9>] __driver_attach+0x79/0x80
2013-08-31T23:30:07.684513+02:00 linux kernel: 1.682366] <c0537378>] bus_for_each_dev+0x38/0x70
2013-08-31T23:30:07.684515+02:00 linux kernel: 1.682370] <c0538886>] driver_attach+0x16/0x20
2013-08-31T23:30:07.684516+02:00 linux kernel: 1.682373] <c053848f>] bus_add_driver+0x16f/0x270
2013-08-31T23:30:07.684522+02:00 linux kernel: 1.682377] <c0539663>] driver_register+0x63/0x150
2013-08-31T23:30:07.684524+02:00 linux kernel: 1.682381] <c053a49f>] platform_driver_probe+0xf/0x80
2013-08-31T23:30:07.684526+02:00 linux kernel: 1.682384] <c0ae47cc>] vesafb_init+0x1d7/0x20b
2013-08-31T23:30:07.684527+02:00 linux kernel: 1.682387] <c020123a>] do_one_initcall+0x11a/0x170
2013-08-31T23:30:07.684529+02:00 linux kernel: 1.682392] <c0abcae3>] kernel_init_freeable+0x116/0x1b5
2013-08-31T23:30:07.684530+02:00 linux kernel: 1.682396] <c06e4d48>] kernel_init+0x8/0xe0
2013-08-31T23:30:07.684532+02:00 linux kernel: 1.682401] <c070dc67>] ret_from_kernel_thread+0x1b/0x28
2013-08-31T23:30:07.684533+02:00 linux kernel: 1.682404] <c06e4d40>] rest_init+0x70/0x70
2013-08-31T23:30:07.684535+02:00 linux kernel: 1.684743] DWARF2 unwinder stuck at kernel_init+0x0/0xe0
2013-08-31T23:30:07.684541+02:00 linux kernel: 1.684744]
2013-08-31T23:30:07.684543+02:00 linux kernel: 1.684745] Leftover inexact backtrace:
2013-08-31T23:30:07.684545+02:00 linux kernel: 1.684745]
2013-08-31T23:30:07.684546+02:00 linux kernel: 1.684753] — end trace 133f5e15aa569259 ]—

So I know this is error messages related to bug on my laptop bad addressing I/O memspace, but recently his is now fixed , and video card run with 2x2gb ddr dual channel in other distributions without any patch.

Is possible to apply some fix/patch to kernel or pass any special command to kernel before boot to avoid this problem and run this beautiful os with full dual channel setup :slight_smile: ??

Is also possible to try a installing other kernel not listed in repository or recompilation of current kernel including any special modules?

Some link of problem explained and fixed below:

ASUSTeK Computer Inc.-Forum- Which linux distribution

Thanks in advance for any replyes and sorry for mi bad english. Nicola.

Sorry for double post but I not find the edit button …boh

I got a successfully boot in graphics mode with DEBUG kernel and edited kernel boot parameters with grub2 editor at second stage by selecting debug bios and pressing “E” button.

I add this two command
>pcie_aspm=force
and
>pci=realloc

So I now attach my logfiles of current boot with dual channel setup:

Full lspci output > linux-2l97:/usr/share/man # lspci -t -vvv -Q -k -[0000:00]-±00.0 Intel Corpor - Pastebin.com (expired in 1 month)

linux-2l97:/usr/share/man # cat /proc/iomem
00000000-0000ffff : reserved
00010000-0009fbff : System RAM
0009fc00-0009ffff : reserved
000a0000-000bffff : PCI Bus 0000:00
000a0000-000bffff : Video RAM area
000c0000-000cfbff : Video ROM
000d0000-000dffff : PCI Bus 0000:00
000e3000-000fffff : reserved
000f0000-000fffff : System ROM
00100000-bff9ffff : System RAM
00200000-006d142b : Kernel code
006d142c-00a5cc3f : Kernel data
00ae7000-00be3fff : Kernel bss
bffa0000-bffadfff : ACPI Tables
bffae000-bffeffff : ACPI Non-volatile Storage
bfff0000-bfffffff : reserved
c0000000-ffffffff : PCI Bus 0000:00
c0000000-cfffffff : PCI Bus 0000:01
c0000000-cfffffff : 0000:01:00.0
d0000000-d01fffff : PCI Bus 0000:02
d0200000-d03fffff : PCI Bus 0000:03
d0400000-d05fffff : PCI Bus 0000:04
d0600000-d07fffff : PCI Bus 0000:05
d0800000-d09fffff : PCI Bus 0000:05
d0a00000-d0bfffff : PCI Bus 0000:08
d0c00000-d0dfffff : PCI Bus 0000:08
ddf00000-dfefffff : PCI Bus 0000:06
e0000000-efffffff : PCI MMCONFIG 0000 [bus 00-ff]
e0000000-efffffff : pnp 00:0c
fde00000-fdefffff : PCI Bus 0000:01
fdec0000-fdedffff : 0000:01:00.0
fdef0000-fdefffff : 0000:01:00.0
fdf00000-fdffffff : PCI Bus 0000:02
fdfa0000-fdfbffff : 0000:02:00.0
fdfc0000-fdffffff : 0000:02:00.0
fdfc0000-fdffffff : atl1
fe000000-fe0fffff : PCI Bus 0000:03
fe0fe000-fe0fffff : 0000:03:00.0
fe0fe000-fe0fffff : iwl4965
fe100000-fe1fffff : PCI Bus 0000:04
fe1fe000-fe1fffff : 0000:04:00.0
fe1fe000-fe1fffff : ahci
fe200000-fe9fffff : PCI Bus 0000:06
fea00000-feafffff : PCI Bus 0000:09
feafe800-feafe8ff : 0000:09:01.3
feafe800-feafe8ff : r852
feafec00-feafecff : 0000:09:01.2
feafec00-feafecff : r592
feaff400-feaff4ff : 0000:09:01.1
feaff400-feaff4ff : mmc0
feaff800-feafffff : 0000:09:01.0
feaff800-feafffff : firewire_ohci
febf8000-febfbfff : 0000:00:1b.0
febf8000-febfbfff : ICH HD audio
febff000-febff3ff : 0000:00:1d.7
febff000-febff3ff : ehci_hcd
febff400-febff7ff : 0000:00:1a.7
febff400-febff7ff : ehci_hcd
febff800-febfffff : 0000:00:1f.2
febff800-febfffff : ahci
fec00000-fec003ff : IOAPIC 0
fed00000-fed003ff : HPET 0
fed14000-fed19fff : pnp 00:01
fed1c000-fed1ffff : pnp 00:08
fed1f410-fed1f414 : iTCO_wdt
fed1f410-fed1f414 : iTCO_wdt
fed20000-fed3ffff : pnp 00:08
fed45000-fed89fff : pnp 00:08
fee00000-fee00fff : Local APIC
fee00000-fee00fff : reserved
fee00000-fee00fff : pnp 00:0a
ffb00000-ffffffff : reserved
ffb00000-ffbfffff : pnp 00:08
fff00000-ffffffff : pnp 00:08
100000000-13fffffff : System RAM

And messages log will follow later because is very huge to handle in 5 mins growht up to 2.5 GB !!
I now reboot and try to pass kernel command over DESKTOP kernel.

Hello and welcome here.

I do not know if you still need advice, but please saying you have installed openSUSE 12, does not tell people here very much. Please be precise and tell what version you realy have. When you have forgotten, you can find out with

cat /etc/SuSE-release

Also, you tried to make a visual difference between your text and the and computer facts. That is very fine. But please do not use the QUOTE taggs for computer text (that is for quoting “normal” text), but use CODE tags. You get them by using the # button in the tool bar of the post editor.

Ho yes! sorry man for my noob errors :slight_smile: , and thank for you reply.
Now I be more accurate

babiz@linux-2l97:~/logfile> cat /etc/SuSE-release
openSUSE 12.3 (i586)
VERSION = 12.3
CODENAME = Dartmouth

Because the messages logfile is about 2.5 gb of textplain :smiley: lol …very difficult for me to handle (kwrite crashes on loading and

cat messages |more

require unknown time to scroll down by holding enter key heheh) and so giving up!

I rebootet and pass to kernel the two parameters above i mean at precedent post

pcie_aspm=force pci=realloc

Reported me by looking at kernel log as “suggestion to run”… wow! very impressive!

The good news is the DESKTOP kernel works well and I successfully booted into kde environment (after cleared big logfile and /tmp directory)
http://s23.postimg.org/uncsdy7rr/schermata1.jpg](http://postimg.org/image/uncsdy7rr/)
So seems the system works absolutely fine. Now only remain to edit boot options using Yast2 control center.
http://s23.postimg.org/luvtq9mmv/schermata2.jpg](http://postimg.org/image/luvtq9mmv/)

Thanks again for us attention and hope this post is useful for others.