Can't update/upgrade old installation 12.3

I have an openSuse system that I use for software development, and I would rather leave it as is.
But if I try to install software, there is no repository there to talk to!

@linux-cyy8:~/artisan/sound> sudo zypper refresh
Repository 'openSUSE-12.3-1.7' is up to date.
File '/content' not found on medium ''

Abort, retry, ignore? [a/r/i/? shows all options] (a): 
ABORT request: Aborting requested by user

There is no 12.3 under
Or in
Is there any way I can update or upgrade this system online?

Hi and welcome to the forum :slight_smile:
Well 12.3 was discontinued in January 2015…

Have a look here for what’s available and change your repository links to point at a EOL mirror to see what you can get.

I wouldn’t even attempt an upgrade… backup your data and re-install to a supported release…

Some months ago, I upgraded from 12.3 using zypper dup to first 13.1 and now am on 13.2. Here is a link to the thread I started on this topic.

Assuming the 12.3 you have is fully up-to-date. You could try upgrading one release a time at least as long as 13.1 and 13.2 still have their repositories up. This process worked with a few hiccups for me. As I understand it after OpenSuse 13.2 comes OpenSuse Leap 42.1, which for me would involve a switch from KDE 4.x to KDE 5.x. I have not tried upgrading past 13.2 yet, so I do not know how smoothly this would go. I should point out I was advised not to try upgrading and just to do a fresh install.

The time it takes and the possible problems it seems to me it is far easier to note the programs you use and save /etc (for reference) and home partition and do a fresh install. If you miss some programs it only takes minutes to install when you notice. Your home has all your configurations and /etc has most of the system configuration. Upgrading takes longer and is more prone to odd problems.