Cant update to openssh-9.6p1 crypto-policies too old

Hi all,

I am getting an error when trying to update to the newest openssh package (openssh-9.6p1-lp155.11.1.x86_64 ) on openSUSE leap 15.5. It says, no repo provides the needed version of crypto-polices.

zypper update openssh
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Problem: 1: nichts stellt 'crypto-policies >= 20220824' bereit, das vom zu installierenden openssh-server-9.6p1-lp155.11.1.x86_64 benötigt wird
 Lösung 1: openssh-9.6p1-lp155.11.1.x86_64 nicht installieren
 Lösung 2: openssh-server-9.6p1-lp155.11.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/a/d/?] (a): 

My currently installed versions are:

zypper info openssh
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...


Informationen zu Paket openssh:
-------------------------------
Repository         : Networking services and related tools (15.5)
Name               : openssh
Version            : 9.6p1-lp155.11.1
Arch               : x86_64
Anbieter           : obs://build.opensuse.org/network
Installierte Größe : 0 B
Installiert        : Ja
Status             : veraltet (Version 9.3p2-lp155.3.2 installiert)
Quellpaket         : openssh-9.6p1-lp155.11.1.src
Upstream-URL       : https://www.openssh.com/
Zusammenfassung    : Secure Shell Client and Server (Remote Login Program)
Beschreibung       : 
    SSH (Secure Shell) is a program for logging into and executing commands
    on a remote machine. It replaces rsh (rlogin and rsh) and
    provides secure encrypted communication between two untrusted
    hosts over an insecure network.

    xorg-x11 (X Window System) connections and arbitrary TCP/IP ports can
    also be forwarded over the secure channel.

    This is a dummy package that pulls in both the client and server
    components.
zypper info crypto-policies
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...


Informationen zu Paket crypto-policies:
---------------------------------------
Repository         : Update repository with updates from SUSE Linux Enterprise 15
Name               : crypto-policies
Version            : 20210917.c9d86d1-150400.3.6.1
Arch               : noarch
Anbieter           : SUSE LLC <https://www.suse.com/>
Installierte Größe : 87,6 KiB
Installiert        : Ja (automatisch)
Status             : aktuell
Quellpaket         : crypto-policies-20210917.c9d86d1-150400.3.6.1.src
Upstream-URL       : https://gitlab.com/redhat-crypto/fedora-crypto-policies
Zusammenfassung    : System-wide crypto policies
Beschreibung       : 
    This package provides pre-built configuration files with
    cryptographic policies for various cryptographic back-ends,
    such as SSL/TLS libraries.

I found a hint for a kind of a “patch” under:

But this seems to related to tumbleweed.

Do you know how to solve my problem to update my openssh packages?

Thanks a lot.

Segler

Please post the complete output incl. the complete input line.

PS:
openssh-server in Leap 15.5:

i+ | openssh-server                    | Paket      | 8.4p1-150300.3.37.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v  | openssh-server                    | Paket      | 8.4p1-150300.3.30.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v  | openssh-server                    | Paket      | 8.4p1-150300.3.27.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v  | openssh-server                    | Paket      | 8.4p1-150300.3.22.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v  | openssh-server                    | Paket      | 8.4p1-150300.3.18.2 | x86_64 | Haupt-Repository

And post commands with English output - it is English speaking forum.

Where exactly have you got it from? There is no such package in Leap 15.5 repositories.

@SeglerEDCE your using non standard repositories, hence your issue…

Hi all,

thank you for the fast replies.

@Sauerland: Thanks for the hint. I added the complete output.

@arvidjaar: I am sorry, i changed it.
I get the packaage from "obs://build.opensuse.org/network repo

@malcolmlewis: Thanks for the hin. I will change to the standard repo.

Segler

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.