Can't update Suse 11.0

When I press on the update button in the lower right corner I get told that I have 44+ updates available. If I click install I enter my admin password and then nothing happens. It just displays the red triangle again in the lower right corner where I could do the same thing again 100 times not updating anything.

When I go see the details and e.g. just mark the first 2 updates (which is something with aaa) I get the following error:

Can’t provide file ‘./rpm/i586/aaa_base-11.0-79.1_79.5.i586.delta.rpm’ from repository ‘openSUSE-11.0-Updates’

What is going wrong?

Try doing it in a console
Type su then root pass then zypper ref (refreshes the repos) then zypper up (to update) If there are dependency issues it will give you options

Geoff

I did that. It starts an download/install of several updates. However it never finishes. Everytime after a while it stops with following message:

Repository ‘openSUSE-11.0-Updates’ is out of date. Running ‘zypper refresh’ might help.

And ofc ‘zypper refresh’ was just what I was doing before running the update.
So everytime I run zypper ref && zypper up I get a bit further but it always ends with this message.

Ok, after repeating the whole thing like 30 times it finally managed to get all updates. But can anyone tell me, why it always stopped with that Repository error message?

No one that could tell me, why I get this error message all the time?

#----------------
Downloading package autoyast2-installation-2.16.19-0.1.noarch (21/130), 175.0 K (1.2 M unpacked)
Downloading: autoyast2-installation-2.16.19-0.1.noarch.rpm [done]
Downloading: repomd.xml [done]
Problem downloading the package file from the repository:
Can’t provide ./rpm/noarch/autoyast2-installation-2.16.19-0.1.noarch.rpm : Can’t copy /var/adm/mount/AP_0x00000001/rpm/noarch/autoyast2-installation-2.16.19-0.1.noarch.rpm to /var/cache/zypp/packages/openSUSE-11.0-Updates
Repository ‘openSUSE-11.0-Updates’ is out of date. Running ‘zypper refresh’ might help.
#----------------

If I do zypper dup again I just wait again to get a similar message again:

#----------------
Downloading: mozilla-xulrunner190-gnomevfs-1.9.0.5-0.1.i586.rpm [done]
Downloading: repomd.xml [done]
Problem downloading the package file from the repository:
Can’t provide ./rpm/i586/mozilla-xulrunner190-gnomevfs-1.9.0.5-0.1.i586.rpm : Can’t copy /var/adm/mount/AP_0x00000001/rpm/i586/mozilla-xulrunner190-gnomevfs-1.9.0.5-0.1.i586.rpm to /var/cache/zypp/packages/openSUSE-11.0-Updates
Repository ‘openSUSE-11.0-Updates’ is out of date. Running ‘zypper refresh’ might help.
#-----------------

Couldn’t update from the icon in the desktop panel, so did sudo zypper ref and sudo zypper up. Rebooted. Now I get an error message “Could not start kdeinit4. Check your installation.”

Confirmed that the file exists (in /usr/bin/) and that everyone has permission to execute.

Is the file in the wrong directory? Any other hints?
Thanks.

After a reboot, the openSUSE 11 updater worked. Another cure attributable to spontaneous remission.