Can't Update - Chromium-FFmpeg requires Chromium

Hi, for the past few weeks I can’t update my system any more. Here’s my error:

chromium-ffmpeg-45.0.2454.85-50.1.i586 requires chromium = 45.0.2454.85, but this requirement cannot be provided

I’m running:

Linux 3.16.7-24-desktop
openSUSE 13.2 (Harlequin) (i586)

KDE platform: 4.14.9


Any ideas?

There might be a problem with your repos.

What’s the output from:

 zypper lr -d

Please use code tags to post. The “#” button on the editor will generate code tags, and you can paste the output between them.

There is no Update for chromium-ffmpeg on 32 bit to Version 45.0.2454.101-54.1:

zypper se -s chromium-ffmpeg
Daten des Repositories laden ...
Installierte Pakete lesen ...

S | Name                      | Typ   | Version            | Arch   | Repository          
--+---------------------------+-------+--------------------+--------+---------------------
i | chromium-ffmpeg           | Paket | 45.0.2454.101-54.1 | x86_64 | Packman-Mirror      
v | chromium-ffmpeg           | Paket | 45.0.2454.85-50.1  | i586   | Packman-Mirror

Maybe an Error on Packman or it will not build, I do not know.

Install the former Version of Chromium:

v | chromium                          | Paket      | 45.0.2454.85-43.1  | i586   | openSUSE-13.2-Update

What is this “v | chromium” line? It doesn’t work in the terminal. Sorry.
I tried unclicking chromium in the Software Management but I’m not sure how to install a specific version afterwards. :expressionless:

Install chromium in Version 45.0.2454.85-43.1:

zypper in -f chromium-45.0.2454.85-43.1

What is this “v | chromium” line? It doesn’t work in the terminal. Sorry.

Its one Line from:

zypper se -s chromium-ffmpeg

Ok, I just did

zypper in -f chromium-45.0.2454.85-43.1

as su, logged out and back in, still getting an error in updates:

chromium-ffmpeg-45.0.2454.85-50.1.i586 requires chromium = 45.0.2454.85, but this requirement cannot be provided

I suppose i’ll just uninstall chromium all together.

Post:

zypper se -si chromium
uname -a

And Packman Repo is enabled?

Post:

zypper se -si chromium
Loading repository data...
Reading installed packages...

S | Name                  | Type    | Version           | Arch | Repository            
--+-----------------------+---------+-------------------+------+-----------------------
i | chromium              | package | 45.0.2454.85-43.1 | i586 | Main Update Repository
i | chromium-desktop-kde  | package | 45.0.2454.85-43.1 | i586 | Main Update Repository                                                                  
i | chromium-ffmpeg       | package | 45.0.2454.85-50.1 | i586 | Packman Repository                                                                      
i | chromium-pepper-flash | package | 19.0.0.185-1.1    | i586 | Packman Repository      
uname -a
Linux linux-j827 3.16.7-24-desktop #1 SMP PREEMPT Mon Aug 3 14:37:06 UTC 2015 (ec183cc) i686 i686 i386 GNU/Linux 
zypper lr -d
#  | Alias                         | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                      
----------------------------------------------------+--------
 1 | Emulators                     | Emulators                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators/openSUSE_13.2/             |        
 2 | Packman Repository            | Packman Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                       |        
 3 | download.opensuse.org-non-oss | Main Repository (NON-OSS)          | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                   |        
 4 | download.opensuse.org-oss     | Main Repository (OSS)              | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                       |        
 5 | download.opensuse.org-update  | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                      |        
 6 | home:Nemton                   | home:Nemton                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Nemton/openSUSE_13.2/          |        
 7 | libdvdcss repository          | libdvdcss repository               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                           |        
 8 | nVidia Graphics Drivers       | nVidia Graphics Drivers            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/13.2/                                      |        
 9 | openSUSE-13.2-0               | openSUSE-13.2-0                    | Yes     | ( p) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-SONY_CD-RW_DVD-ROM_CRX330E_2005011200054152 |        
10 | repo-debug                    | openSUSE-13.2-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                 |        
11 | repo-debug-update             | openSUSE-13.2-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                |        
12 | repo-debug-update-non-oss     | openSUSE-13.2-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                        |        
13 | repo-source                   | openSUSE-13.2-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                |        
14 | repo-update-non-oss           | openSUSE-13.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ 
still getting an error in updates:

If you do an zypper up?

That is normal because chromium will be updated to Version 45.0.2454.101-50.1 and for that Version there is no chromium-ffmpeg in 32-bit…
So chromium-ffmpeg will say, that there is no chromium in Version 45.0.2454.85 installed after that Update.

So pin chromium from update:

zypper al chromium

See

zypper al --help

Ok, I zypper pinned chromium, then did a zypper update, restarted, and now have 1 new update, with the new errorr:

patch:openSUSE-2015-649-1.noarch conflicts with chromium.i586 < 45.0.2454.101-50.1 provided by chromium-45.0.2454.85-43.1.i586

Thats also because of that Error.

So delete chromiuim and install another Browser or live with them until a patch is delivered.