Can't update amarok to play mp3s

Greetings all,

Linux noob here - I’ve installed Opensuse 11.4 and even have the multiboot working (at last) and firefox running at more than a snails pace, but this latest problem is really stumping me. I suspect it might be a little more fundamental than just amarok and mp3’s but that’s where I see it.

So, when I run amarok it asks if I would like to install MP3 support (yes please!) So I click on affermative and, since I added the neccessary repositories, it starts merrily into updating. Then after a few files it his this one:


98MB. It downloads all the way to 99% and then the transfer rate drops from the 120KB/s I expect to 8B/s for a minute or so nad then it just restarts from 0%. It will do this a few times before offering the opportunity to skip. I did skip and it did a few more files successfully then hung up in the same way. It seems like any file larger than 1MB will not download.

Any ideas on what I should do to fix this?

thanks in advance!!!

You need to go here and do some reading:

New User How To/FAQ (read only)

You need to add the repository called Packman, but the address varies based on your openSUSE version, which you did not state in your message. I assume you must be using KDE because of the Amarok question, but not sure. Do some reading and get back with us.

Thank You,

Cool! Thank you.

OK, so I tried to follow the instructions here:

Multi-media and Restricted Format Installation Guide

but when it’s time to install the listed packages everyting goes south. A few packages would load but I was still hanging up at 99% with the qt4 lib I mentioned above and restarting automatically. If I skip it would hang up on other packages. I think it hangs on anything from OSS. I tried running software update from yast with the same sorts of problems. Anyway, my feeling is that this is not a multimedia issue but rather something wrong with installing updates and new packages, so I am reading a bit about it and trying a few things. I guess it would make sense for me to stop here and start a new thread elsewhere if I am still stuck.

thanks again for your help

PS Opensuse 11.4 and kde.

Just a note to say, in case anyone else is experiencing the same thing, my problem was the bug reported here:

In short an old pc with an old 3com network card can display these issues with certain files from the repos. There is a workaround described but no fix yet.