Can't unmount USB Memory Stick in KDE

Hi!
Now i see that i can’t unmount (Safely remove device) any USB Memory Stick.
If i try to unmount it in KDE, i always get error about one or more files are in use.

But if i execute “umount” in terminal, then it unmount without any problem.

OpenSUSE 11.3 64bits
KDE 4.4.4 Release 3

Do you by any chance have gnome desktop installed also?
And does nautlilus ever open up when you connect a USB?

Same issue. No and no, to the questions. Doesn’t happen when downloading photos from a card using the Gwenview app. Does happen when opening a card or stick in Krusader, even if Krusader is closed before trying to dismount.

I don’t have this problem
But I’ll re-visit dolphin now with a USB to double check.

Hi!
No i don’t have GNOME installed, but there is som GNOME-application that is installed.
If i plugin a usb-ms Nautilus opens automatic. Why does Nautilus open when Dolphin is default filebrowser?
There is no problem mounting usb-ms, but only when i want to unmount in KDE.

If nautilus opens try leaving it open and safely removing with that. I bet it works.
Nautilus is holding open the drive so dolphin can’t manage it.

Ok! Now i know what is the problem. I have enabled Automatic mount and then Nautilus starts automatic.
Now i have disablet automatic mount, and now i don’t have any problem.

Is it possible to have automatic mount into Dolphin?

System Settings > Removable Devices

On 2010-11-17 12:06, ronnys wrote:
>
> Hi!
> No i don’t have GNOME installed, but there is som GNOME-application
> that is installed.
> If i plugin a usb-ms Nautilus opens automatic. Why does Nautilus open
> when Dolphin is default filebrowser?

If you just once opened Nautilus, then Nautilus takes control. It stays in
the background, doing things like that. It is its duty, designed for that,
as a gnome component.

Kill it, and ensure it is not started automatically on next login - if you
use kde.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Here’s how I solved the problem on my PC (openSUSE 11.3, KDE 4.4 with some Gnome programs):

  1. start nautilus-file-management-properties
  2. go to rightmost tab “Media”
  3. Select “Never prompt or start programs on media insertion”.

Dolphin and device notifier now work as expected for mounting/umounting drives.