cant uninstall opensuse 11.3

hey im new so hello everyone.
i installed opensuse on my acer laptop wich has win xp home sp3. but as i only have a 70gb HD i installed Opensuse on my external WD HDD 1TB i have a 30 GB partition on it so i put it there.
but my problem came when i started my comp without my HDD plugged in and i couldnt load windows. so i was going to uninstall it and create a partition on my laptops HD to put Opensuse on. so after trying to get it removed and getting some info from other forums i repaired the windows MBR which allowed me to boot up windows.
but now after trying to format the partition opensuse was on, my comp can no longer see it. i can not format it with the WD formatting software or through windows computer managment. i have tried partition manager but it cannot read my whole HDD infact it doesnt see any of it, and i tried using the install disc at start up but it is unable to even install on that partition as it cannot use that partition.
i also tried with the win xp disc at start up but it also cant access the HDD

i am also a noob at linux systems and only installed as i wanted to see what it was like and learn about the system

any help is greatly appreciated

Hmm you really did mess up. :slight_smile:

Windows partitioning software is very bad. It really only understands Windows and will ignore all others.

Download Parted Magic. It is much better at dealing with partitions then Windows based tools


try to get use the results of
fdisk -l (that is a lower case L not a one)

Or a picture of the partitioning from the GUI screen.

hi thanks for replying, i tried partition magic 8 and it couldnt even read it either. but i found a very light weight one called Fat32Formatter is freeware and written by TOKIWA and it changed it to fat32 which will do and allow me to reformat to NTFS and recover all the 300GB of film, music, photos and programs.

this will take a while.
but thank you