Can't uninstall Foxit Reader

Can’t uninstall Foxit Reader.
Please check attached screenshot.
Thanks in advance,

Sorry, can’t attached image neither.
Went to the install directory and tried to execute installer: ~/opt/foxitsoftware/foxitreader> sudo ./
The result was this:
QXcbConnection: Could not connect to display
./ line 40: 22955 Aborted (core dumped) $dirname/$appname “$@”

Hi, welcome to the forum.

Please use susepaste - upload the image to - then post the link here:

And it appears not to be an application that you installed from the standard repositories or even from any repository.

This most probably means that it is not installed or even known by many here. So maybe you better explain what you id to install it and where it came from.

It appears to be a piece of proprietary software from provided as a compressed .run file. - Not something I personally would choose to install.


I’ve no idea why it won’t uninstall, perhaps take a look at the “” script - it may be possible to figure out what it removes during uninstall and perform those operations manually.

Or alternatively await to see if there are more constructive replies from other users, but as @hcvv wrote I doubt there will be very many here familiar with the application.

Instead of sudo, login as kdesu or gnomesu and try to uninstall.

Thank you all.
Well, I’ve tried to execute with sudo and it didn’t work.
I then logged as root, executed the file and it worked.