Can't transfer mp3s between drives?

How do you move mp3 files between HDDs?

I have a dual boot setup with XP/OS11.
I have no problem dragging mp3s from the windows partition into the Suse partition and playing them but when I try to drag mp3s from Suse to XP it won’t go, says permission denied.

Just used K-Torrrent to give it a try and DL an album. Album came out great. Then tried to move it over to my Ext HDD and then the XP partition but it wouldn’t let me.
What do you have to do to be able to move mp3s from Suse to an ext HDD and the XP partition?
When I use Ubuntu there is no problem here, you just easily drag mp3 files back and forth between XP and Ubuntu or Vista and Ubuntu.

It’s an NTFS write issue
post your /etc/fstab here

Read this
HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

Got this output:
tt@linux-4uyb:~> /etc/fstab
bash: /etc/fstab: Permission denied
tt@linux-4uyb:~>

Looked at your link. Wow!
It will take some time to digest that info.

Ubuntu was much simpler, it just did it by default…

I have no problems playing mp3s from the Ext HDD and the XP partition in Suse and both of them partitions are NTFS.

OK, out of the blue this just popped up on my screen:

/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part7 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part8 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part9 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Its actually fairly simple. But the link tries to handle many cases, and give an explanation, so it looks more complex than it is. Having some linux knowledge (especially terminal/command-line knowledge) also helps.

wrt your fstab, it is a text file under the directory /etc. To see its contents type: cat /etc/fstabwhich lists what partitions your openSUSE will try to mount.

Also useful, is the output of typing: df -hwhich lists what partitions your openSUSE successfully mounted.

and also useful the output of typing: su -c 'fdisk -l’enter root password when prompted. It will list what partition IDs your openSUSE has successfully identified (although possibly not mounted).

If you can not understand the URLs provided, then post here the output of the above commands, and one of the users/readers of this thread can provide you the necessary edit to get your NTFS write access working properly.

Here’s the output requested:

tt@linux-4uyb:~> cat /etc/fstab
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part7 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part8 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part9 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 00
sysfs /sys sysfs noauto 00
debugfs /sys/kernel/debug debugfs noauto 00
devpts /dev/pts devpts mode=0620,gid=5 00
tt@linux-4uyb:~> df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda8 7.2G 2.5G 4.4G 36% /
udev 189M 120K 188M 1% /dev
/dev/sda9 11G 660M 9.6G 7% /home
/dev/sda1 19G 7.3G 12G 39% /windows/C
/dev/sda5 38G 387M 37G 2% /windows/D
/dev/sda6 38G 13G 26G 33% /windows/E
/dev/sdb7 37G 2.6G 35G 7% /media/SCSI
/dev/sdb5 38G 33G 5.0G 87% /media/SCSI-1
/dev/sdb6 38G 30G 8.1G 79% /media/Thad
/dev/sdb1 38G 4.8G 33G 13% /media/SCSI-2
tt@linux-4uyb:~> su -c ‘fdisk -l’
Password:

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x018d8dfc

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2432 19535008+ 7 HPFS/NTFS
/dev/sda2 2433 14593 97683232+ f W95 Ext’d (LBA)
/dev/sda5 4865 9695 38804976 7 HPFS/NTFS
/dev/sda6 9696 14593 39343153+ 7 HPFS/NTFS
/dev/sda7 2433 2493 489919+ 82 Linux swap / Solaris
/dev/sda8 2494 3441 7614778+ 83 Linux
/dev/sda9 3442 4864 11430216 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x09ddfa3c

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 4897 39335121 7 HPFS/NTFS
/dev/sdb2 4898 19456 116945167+ f W95 Ext’d (LBA)
/dev/sdb5 4898 9750 38981691 7 HPFS/NTFS
/dev/sdb6 9751 14636 39246763+ 7 HPFS/NTFS
/dev/sdb7 14637 19456 38716618+ 7 HPFS/NTFS
tt@linux-4uyb:~>

PS: in case it matters, the Ext HDD is turned on.

OK, I see two hard drives, hard-drive-a and hard-drive-b. It appears hard-drive-b is an external hard drive, partitioned into different NTFS formatted partitions.

I note you are using fmask. Is that necessary? If not, then I recommend you make a backup copy of your /etc/fstab, and then change your /etc/fstab to:

/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part7 swap                 swap       defaults              0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part8 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part9 /home                ext3       acl,user_xattr        1 2
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part1 /windows/C           ntfs-3g    user,users,gid=users,umask=0002,locale=en_US.UTF-8  0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part5 /windows/D           ntfs-3g    user,users,gid=users,umask=0002,locale=en_US.UTF-8  0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part6 /windows/E           ntfs-3g    user,users,gid=users,umask=0002,locale=en_US.UTF-8  0 0
proc                 /proc                proc       defaults              00
sysfs                /sys                 sysfs      noauto                00
debugfs              /sys/kernel/debug    debugfs    noauto                00
devpts               /dev/pts             devpts     mode=0620,gid=5       00 

wrt your external NTFS drive, I recommend you unplug the drive, and then as a work-around to this issue (where your external hard drive is not mounted with read-write permissions) is to create a symbolic link in /sbin. Specifically open a gnome-terminal or konsole and type:cd /sbin
su -c 'ln -s mount.ntfs-3g mount.ntfs’and then plug your external hard drive in, and it should be hot plug automounted with read-write permissions.

A caution here … be VERY exact in how you make these edits. I tried to be exact in what I gave.

If you make an editorial mistake, your PC may not properly boot.

Also, after making the fstab edits, you will need to reboot to have it loaded.

Good luck.

Thanks…:wink:
OK, did that and the Ext HDD now works so I can move files from SUSE into it. This was my main concern.
Is there a similar quick code for the main HDD?

For the main HDD you need to apply the fstab edit that I provided, and then reboot.

Tried that and it still won’t work.
I put that code you posted in the box in post#7, in terminal, then reboot and no change, hope I did it correctly. I still can’t drag files from SUSE into the XP partitions while running SUSE on that XP/SUSE dual boot setup. However I can move files from SUSE to the ext HDD now.

I discovered a work around where it is possible to move those files when I reboot into XP on that XP/SUSE dual boot setup. Running XP these same files can be moved between SUSE, Ubuntu, XP & Vista with no problems.

Post here the output of: cat /etc/fstab
and we can do a quality check of your edit.

Here’s the output:

tt@linux-4uyb:~> cat /etc/fstab
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part7 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part8 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part9 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 00
sysfs /sys sysfs noauto 00
debugfs /sys/kernel/debug debugfs noauto 00
devpts /dev/pts devpts mode=0620,gid=5 00
tt@linux-4uyb:~>

You don’t seem to have made the changes oldcpu was suggesting.

I suggest you manually make a backup of /etc/fstab

Now open it (the actual file, not the copy) in file manager super user mode.

edit to:

/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part7 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part8 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part9 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part1 /windows/C ntfs-3g user,users,gid=users,umask=0002,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part5 /windows/D ntfs-3g user,users,gid=users,umask=0002,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part6 /windows/E ntfs-3g user,users,gid=users,umask=0002,locale=en_US.UTF-8 0 0
proc /proc proc defaults 00
sysfs /sys sysfs noauto 00
debugfs /sys/kernel/debug debugfs noauto 00
devpts /dev/pts devpts mode=0620,gid=5 00

reboot

Thanks for the reply, caf4926.
This is something new I’ve never done before.
Could you help walk me through it so I don’t mess things up?

Start- system- file manager -file manager super user mode

navigate to /etc

open /etc/fstab (right click it - open with kwrite)
save as: fstabold
close

Now open /etc/fstab again - right click open with kwrite
delete all the text and paste in:

/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part7 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part8 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part9 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part1 /windows/C ntfs-3g user,users,gid=users,umask=0002,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part5 /windows/D ntfs-3g user,users,gid=users,umask=0002,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3120814A_4LS4S760-part6 /windows/E ntfs-3g user,users,gid=users,umask=0002,locale=en_US.UTF-8 0 0
proc /proc proc defaults 00
sysfs /sys sysfs noauto 00
debugfs /sys/kernel/debug debugfs noauto 00
devpts /dev/pts devpts mode=0620,gid=5 00

SAVE

reboot

caf4926,
Thanks!
Success, that did the trick!..:wink:
Wow. First time ever doing something like that.
Your directions were a great help, even though I had to muddle my way along figuring it out as I followed them.

I can now move files from the SUSE partition into the XP NTFS partition of the dual boot desktop and play them in that XP partition with a SUSE player.

The only thing is when files are done moving over there, this message box pops up:

Informatic
Could not change permissions for
/windows/D/03- Smooth Operator.mp3

They play fine.
I assume there will be no problem burning them.
Is that correct?

You should be fine.

Most of the credit should go to oldcpu he is a real guru.

May I suggest you now make a text file with the contents of your fstab, and call it say: fstab backup.txt
and save it somewhere to your /home/user*

Just in case.

I see you are using kde4.0.4
Might we suggest you also install kde3 by going to software management, filter by patterns and add kde3base and kde3desktop.

Burning: k3b is what you need, and only the Packman version.

cybrsaylr, Congratulations. Glad caf4926 was able to sort/translate what was provided.

Contrary to caf4926’s nice words, I’m far from a guru (although there are some real guru’s who frequent this forum - I’m just not one of them). As you learn more you will find a lot of this comes second nature, but of course there is always more to learn.

A nice thing about Linux is there is no “registery”, … instead almost all settings are in an ascii text configuration file … but of course it takes time and effort to learn where everything is, and then even more time to learn how to “tune” it.

You may find it useful to read the following openSUSE concepts guide. Its rather basic, but it does provide a very general simple top level overview of openSUSE Linux, and may help explain a bit why things “are the way they are”. Concepts - openSUSE

Good luck!