Can't Switch Back to X after Ctrl-Alt-F1 in 10.2 w/ nvidia

When in X or Gdm, if I switch to a virtual terminal, I can’t switch back to X, or any other virtual terminal.

X does not crash, its still running, I just can’t get back to it.

I have an nvidia Quadro FX 1700, and the latest nvidia drivers from the opensuse repositories.

Any help?

TIA!

R.

You don’t say what you have done to try to get back into X.

I am assuming that you know that your X session is on vt7 and is therefore accessed by pressing ctl/alt/F7? That is the first thing to try.

If you have already done that and it doesn’t work then what error messages do you get, or what happens?

yes I have tried alt-F7 and ctrl-alt-F7 (I was implying that when I said I can’t switch back)

Nothing happens with A-C-F[1-12] either.

I found this:
*(http://ubuntuforums.org/showthread.php?t=188382)

and this:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/129910

And these lead to the ‘VGA=xxx’ option in the boot manager.*

title openSUSE 11.0 - 2.6.25.11-0.1 (default)
root (hd0,8)
kernel /boot/vmlinuz-2.6.25.11-0.1-default root=LABEL=spare splash=nosplash showopts vga=0x314
initrd /boot/initrd-2.6.25.11-0.1-default

That is the menu.lst entry for my installation. As you can see it has a vga= entry in it, not that I put it there, it was there by default.

You can copy that if you like, but tbh I don’t know what it does.

If the above doesn’t work for you I have a workround you might like to try, although I can’t guarantee it will work as the problem I was dealing with when I used it was not exactly the same as yours.

When you get into the login screen, login as root then type

service dm stop

which should stop your desktop manager (or it does on Mandirva - haven’t tried it on Suse)

then type

login

which will give you another login prompt. Login as a normal user and then type

startx

Not ideal I must admit, but if you are stuck it is probably faster than a reboot (assuming it works of course!)

I did a new login from X (gdmflexiserver) and it switched to the new login.

I was then able to switch from one to the other and back with ctl-alt-f7 <–> ctl-alt-f8.

And as I said I can get to a TTY from X but I can’t get back to X from a TTY.

I suspect that there is something about the TTY terminal that is not seeing the function keys on the keyboard, which is a Microsoft Natural 4000 V1.0 (usb)

I guess I’ll try plugging in a ps2 keyboard and see if that makes a difference.

I managed to get back to my X session by pressing the small ‘windows key’ + F7 (beside RH Alt) I was thinking that was rather strange too. :slight_smile:

I just found this post and your suggested combo (“super + alt + F7” in my case) and finally brought me back to the x session.

Is it weird or normal? (always thought I had go press CTRL + Alt + FN)

thanks :slight_smile:

This is normal. Sometime it might be CTRL-ALT-F8, so try that if CTRL-ALT-F7 doesn’t do what you expected.