Can't switch back to openSUSE input on monitor

I have an HD monitor that has a Chromecast in one input and my computer running openSUSE in the other. When I swithc the monitor’s input to the Chromecast, it works perfectly. But when I try to switch back, it simply goes dark for about 5-10 seconds and then switches back to Chromecast. No matte how many times I try, it won’t go to openSUSE.

I think it’s because openSUSE is somehow not communicating with the monitor to let it know something is there.

If I unplug Chromecast, then it switches to openSUSE.

How can I figure out what’s causing this and fix it?

openSUSE 13.2 (KDE)
ViewSonic VX2453mh-LED

Well touch the keyboard or mouse. Maybe it has gone to sleep

You can set power down time for monitor in configure desktop power management.

If the problem is if you turn it on while set to video then maybe your monitor is not seen by the system and it thinks it is headless. In which case you need to hard code the monitor spec into the xorg.conf files

Tried this, doesn’t work. I move the mouse back and forth, type keys, hit the volume button on keyboard - nothing works.

That’s not it. If I switch to CHromecast and then back even a few minutes later, it doesn’t work. Unplugging chromecast shows the openSUSE desktop without any screensaver (which I turned off).

Can you tell us more details about your graphics card and driver?

hwinfo --gfxcard
08: PCI 01.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.328]
  Unique ID: vSkL.BFqQkb3Goo0
  SysFS ID: /devices/pci0000:00/0000:00:01.0
  SysFS BusID: 0000:00:01.0
  Hardware Class: graphics card
  Model: "ATI Sumo [Radeon HD 6410D]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x9644 "Sumo [Radeon HD 6410D]"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x061d 
  Driver: "radeon"
  Driver Modules: "drm"
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf0ff (rw)
  Memory Range: 0xfef00000-0xfef3ffff (rw,non-prefetchable)
  IRQ: 48 (349779 events)
  Module Alias: "pci:v00001002d00009644sv00001025sd0000061Dbc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is active
    Driver Activation Cmd: "modprobe radeon"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #8

I’d focus on the Viewsonic’s switching first. Are you able to test this monitor similarly with another computer, preferably one with another OS (like Windows)?..maybe borrow somebody’s laptop for a couple of minutes.

I’ll give that a try and report back.

I checked it against a Windows 8 laptop and it switches perfectly every time. I switched back and forth 6 times and it always switched.

So it is an openSUSE issue.

Any ideas for what I can do to figure this out?

So what inputs are you using, hdmi for chromecast, vga for computer, or hdmi for both, dvi? What is the monitor, model/brand?

HDMI for both.

ViewSonic VX2453mh-LED

Is using the proprietary AMD/ATI driver an option here? (Assuming it’s a driver-related issue of course.)

I was thinking the radeon driver module options…? dpm and disp_priority? Then maybe xset options?

@6tr6tr is the acer plugged into the I guess hdmi1 port (primary) on the monitor?

Whoa, not so fast grasshopper ;). That’s good that you’ve eliminated the monitor, but the other end of the hardware equation is, of course, your computer. While simultaneously looking into a software solution, you might want to try testing whether a hardware problem exists by booting another OS on it. Ideally, a Windows OS, but understand that is not necessarily feasible … though, you most certainly could try testing another linux distro with a live disc or usb key.

Hmmm, no I just checked and it’s in HDMI-2. I’ll switch and see if that makes a difference. (Although, it still worked when it was a Windows computer plugged into slot #2)

Switched them and it still won’t go back to openSUSE (now in port #1) when on Chromecast.

How would I change those and test them?

On Wed 14 Oct 2015 06:26:02 PM CDT, 6tr6tr wrote:

malcolmlewis;2732169 Wrote:
> Hi
> I was thinking the radeon driver module options…? dpm and
> disp_priority? Then maybe xset options?

How would I change those and test them?

Create a file in /etc/modeprobe.d called 50-radeon.conf and in that
file add;

options radeon disp_priority=2 dpm=1

For all the options/settings see the otput from;

/sbin/modinfo radeon

To see what options are set run all on one line as root user (run
before and after a reboot);

ls /sys/module/radeon/parameters/ | while read parameter; do echo -n "Parameter: $parameter --> "; cat /sys/module/radeon/parameters/$parameter; done;

Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.44-52.18-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Thank you. Are there any risks in making those changes?

Right now, it’s set to:


I would set the priority option only then, 2 set’s it high and see if it works better than auto.