Can't start X server and can't install NVIDIA display driver when upgrade to 11.3 from 11.2

Hi, all,

I upgrade to 11.3 from 11.2 according to official portal “system upgrade”.

#zypper ref
#zypper dup

After complete, I restart the system, it just can login in by terminate.
When I run


Got below message:

Current version of pixman: 0.18.0
Before reportign problems, check help http://wiki.x.og
to make sure that you have the latest version.
Markers: (–) probed, (**)from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sun Jul 18 20:49:38 2010
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using config directory: “/etc/X11/xorg.conf.d”
(EE) module ABI major version (2) doesn’t match the server’s version (3)
(EE) Failed to load module “glx” (module requirement mismatch, 0)
(EE) Failed to load module “nvidia” (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

giving up.
xinit: No such file or directory (error 2): unable to connect to X server
xinit: No such process (error 3): Server error.

And downloaded NVIDIA driver from NVIDIA site, and ran it:

$ sh 

And got below error message:

ERROR: Unable to load the kernel module ‘nvidia.ko’. …

I try a lot of method, but can’t solved this problem. Hope someone can help me, thanks!

openSUSE Graphic Card Practical Theory Guide for Users

SDB:NVIDIA drivers - openSUSE

Check the details on adding nomodeset to boot arguments

Make sure you try this too:

In cases when there is still a problem set the NO_KMS_IN_INITRD sysconfig variable to yes via yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD.

Thank you very much! It’s working now!

Good news, well done!