Cant start plasma(X11) after upgrade from leap 15.4 to tumbleweed


I did a distro upgrade from leap 15.4 to tumbleweed, and on the login screen I get a screen to choose a user to log into, and on the upper right corner I can choose booting into different desktops, when i login on plasma(X11), I get a brief black screen then back to the same login screen, however when I change into plasma(weyland) I can log into the desktop.

after some searching online I found the following, whenever I run startx in the terminal I get the following:

elias@tower:~> startx
xauth:  file /home/elias/.serverauth.4237 does not exist

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux tower 6.2.9-1-default #1 SMP PREEMPT_DYNAMIC Thu Mar 30 11:30:50 UTC 2023 (7a187a3) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.2.9-1-default root=UUID=87205a0d-eb3d-4345-981d-8bc58e69662f splash=silent preempt=full quiet security=apparmor resume=UUID=87205a0d-eb3d-4345-981d-8bc58e69662f resume_offset=17577216 nosimplefb=1 mitigations=auto
Current version of pixman: 0.42.2
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/elias/.local/share/xorg/Xorg.2.log", Time: Wed Apr 12 19:54:08 2023
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Fatal server error:
(EE) xf86OpenConsole: Cannot open virtual console 3 (Permission denied)
Please consult the The X.Org Foundation support 
 for help. 
(EE) Please also check the log file at "/home/elias/.local/share/xorg/Xorg.2.log" for additional information.
VGA Arbitration: Cannot restore default device.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust /etc/permissions.local and run "chkstat --system --set" afterwards

At first I got an error that opening the /dev/tty0 file failed, but I added my user to the tty group and got the new error: `‘xf86OpenConsole: Cannot open virtual console 3 (Permission denied)’.

I also tried making a new user, and strangley I can log in to that user using the plasma(X11).

any help would be appreciated :slight_smile:

As the package version differences between Leap 15.4 and Tumbleweed are really big, it can happen that you break your user profile. In most cases it is easier to start over with the fresh user profile instead of trying to find the broken culprit in your old user profile…

Migrating to a new user and re-configuring everything seems like a hassle, but if nothing else works guess that’s what ill have to do.

for now I also tried running startx from a non-graphical terminal (Ctrl-Alt-F2) on the login screen and that launched the desktop.

update: Seems like my user is the owner of tty2, and not tty7 (the default graphical terminal), and that allowed me to launch X.