Can't start MySQL after upgrade from 12.3 to 13.1

Hi all,

I upgraded from 12.3 to 13.1 from here:

How To Upgrade From openSUSE 12.3 To openSUSE 13.1 | Unixmen

And the problem I have now when I try to run mysql

rcmysql start

I get this error:

redirecting to systemctl restart mysql
Job for mysql.service failed. See 'systemctl status mysql.service' and 'journalctl -xn' for details.

And executing “systemctl status mysql.service” it says this:

mysql.service - LSB: Start the MySQL database server   Loaded: loaded (/etc/init.d/mysql)
   Active: failed (Result: exit-code) since Mon 2013-12-09 19:50:14 CET; 11min ago
  Process: 4086 ExecStart=/etc/init.d/mysql start (code=exited, status=1/FAILURE)

Dec 09 19:50:14 systemd[1]: Starting LSB: Start the MySQL database server...
Dec 09 19:50:14 mysql[4086]: You are upgrading from different stable version of MySQL!
Dec 09 19:50:14 systemd[1]: mysql.service: control process exited, code=exited status=1
Dec 09 19:50:14 systemd[1]: Failed to start LSB: Start the MySQL database server.
Dec 09 19:50:14 systemd[1]: Unit mysql.service entered failed state.

I don’t know how to resolve this. Maybe I shouldn’t have updated in this way, by it’s done. Anyone knows is there is a solution?


Apparently there’s an issue in MySQL’s upgrade process.
Remove the file /var/lib/mysql/.run-mysql_upgrade and it should start, this worked fine for me at least.

Or uninstall “mysql-community-server”, YaST/zypper should then automatically install “mariadb” instead (a drop-in replacement by MySQL’s original developer, which is now default on openSUSE since 12.3 already). This should also just work.

The first solution worked for me. Thank you very much.