Can't start Mplayer

I install Mplayer from Install/Remove Software and I can’t find it. I reinstall it but without any success.

How to fix that??

The quickest way to see if mplayer works, is to run it from a terminal:

mplayer someapplication.avi

where instead of typing ‘someapplication.avi’ you need to type the file name of the media file you are trying to play.

One way to see if it (and some other media players) are installed is to type:

rpm -qa '*layer*'

You should probably follow this anyway
Multi-media and Restricted Format Installation Guide
scroll up if you are using an earlier version of openSUSE

I have been using OpenSUSE 11.2 with KDE for few months now. I liked it’s support for my Atheros wireless device. The multimedia has been a disappointing experience though. I have followed the instruction from “Multi-media and Restricted Format Installation Guide” and was able to manually start the SMPlayer to play a DVD. I’m surprised that for some reason KDE doesn’t show any option to associate a default app. for automatically playing the DVDs and same goes with the audio CDs (invoke VLC player manually).

I’m sure there are ways to automate these settings and the experience isn’t a pleasant one considering these applications are standard ones for any operating system these days.

After working for few weeks, now the SMPlayer or Kaffeine won’t play a DVD.

Please post result of

zypper lr -d

There are two quick ways to set a default application for a filetype:

  1. Right-click on the file in question. Click properties. You will see a tiny wrench/screwdriver cross icon - click that. (Yeah, it could be more intuitive, I know.) Use the APPLICATION PREFERENCE ORDER dialogue on the bottom half of the window to set preferred applications (and the order in which they are available).

  2. Go to your SYSTEM or DESKTOP SETTINGS application from the K Menu. Click on the ADVANCED tab. Click on “File Associations.” You will see a tree structure on the left. For your purposes, you can expand “Video” or “Audio,” etc. and you will see the same dialogue as in #1 fill the right hand side of the window.

Okay, that should solve your associated program problem. Now I want to share with you why “standard applications” arguments don’t hold water with Linux in general. Linux is about choice and customization. While “video player” may be a common enough application, WHICH video player is an entirely different story.

Thanks for the tips regarding file associations.

I understand Linux is open source and my expectation was from the OpenSUSE distribution which can have a default app associated for video/audio (e.g. in my case Kaffeine never kicks in as an option to play the DVD). Also, a user always has the flexibility to move these settings for his/her perfered application.

Please check this
How to get “play DVD” option when inserting a disk?

Here is the output:

zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±------------------------------±--------------------------±--------±--------±---------±-------±-------------------------------------------------------------±-------
1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
2 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
3 | download.opensuse.org-update | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
4 | packman.inode.at-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /suse/11.2/ |
5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
7 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |

Thanks,

A suggestion, as you have 3 repos twice. You can delete #1,2,3 repos.

Thanks, I have removed the ones you mentioned.

I tried this and it still doesn’t show the option to play the DVD (only gives - rip, download, copy, open, and do nothing).

I tried it and there are too many file types. Which ones belong to DVD playing? I would expect it to play other video formats as well viz. vcd.

Did you try SMPlayer or VLC, you will not face any issue while using these.