Can't shut down (easily)

I upgraded to Suse 11.4, 64-bit a while ago. Everything worked fine. This last week I installed a new NVIDIA graphics card and driver… Now, “Shutdown” takes me to a login screen where I have to select “shutdown” again.

I’ve check rights on the directories. Everything (sbin) seems to match the rights on another machine running OpenSuse 11.3.
I’ve entered “/sbin/shutdown -h -P now” in the session settings (login) to replace “/sbin/halt”.
Xorg.conf has “shutdown=auto”
I’ve re-installed KDE

Is there something else I need to check?

Are you using a desktop or laptop? What brand?

In the meantime:
Try commenting out “shutdown=auto” in your Xorg.conf file.

BTW Why are you still using xorg.conf?



It’s an HP Pavilion desktop that was upgraded from 11.3. I think the Xorg.conf was created because of some software I installed (but right now I can’t remember what). I’ll try taking that line out of the file, but it was working before I started messing with the NVIDIA drivers. About the time I finally found HOW the drivers were supposed to be installed, I started having this shutdown problem.

At the risk of stating the obvious, have you tried to look in /var/log/messages or /var/log/warn, or in dmesg to see if there is an error message at the time of the shutdown to give you a hint as to what is happening. Do NOT post the output of those here !! You need to look at those yourself.

I know. I know. I’m stating the obvious re:checking the logs, but every now and then one stumbles across someone who never checked, … so I thought it worth reminding ‘just in case’. :slight_smile:

well… I’d checked & not found anything glaringly obvious. But then, I’ve poked & prodded the system until I’m a little dizzy.

There is this: linux-wcaf kernel: 41.334127] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
and a string of warnings to do with pulseaudio ratelimit.c about the time of my last shutdown.

I admit to not knowing what to do about either one.

Those read to be associated with your sound during boot, … especially with a time of 41.334127. Are you shutting down after less than a minute of operation ?

no - more like 6-8 hours after boot.
When I started the process of installing new NVIDIA drivers I got a lot of error messages about removing/disabling sound drivers. I kept clicking on “no” or “cancel” or whatever, but I’m not convinced they didn’t get messed up. Sound isn’t critical to what I do, video & network are. Clean shutdown would be nice (I forget & walk away, only to find the thing providing a nightlight I don’t need).

Then you need to focus on those log files at the time that corresponds to the shutdown. There will be some shutdown information. Look for errors or warnings or other indications of a problem with the shutdown (in the log).

Just booted into failsafe to work on this (after not being able to shut down at all) now can’t shut down in failsafe…
found the following in the “warn” log

Sep 23 16:20:13 linux-wcaf pulseaudio[23153]: alsa-sink.c: Most likely this is a bug in the ALSA driver ‘snd_hda_intel’. Please report this issue to the ALSA developers.
Sep 23 16:20:13 linux-wcaf pulseaudio[23153]: alsa-sink.c: We were woken up with POLLOUT set – however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Sep 23 16:22:31 linux-wcaf pulseaudio[23153]: alsa-sink.c: Error opening PCM device front:0: Device or resource busy
Sep 23 16:23:08 pulseaudio[23153]: last message repeated 2 times

seems there might be a sound issue after all

If the times 16:20:13, 16:22:31, and 16:23:08 do not exactly correspond with your shut down times then its HIGHLY unlikely (IMHO) that this is a sound issue. Its more likely something else.

What methods of shutting down have you tried besides those in this thread? Have you tried any methods from this thread: Resolve Linux freeze or hang issues during reboot, restart, shutdown | Debian Ubuntu Linux Solutions Blog

… on a different problem (associated with shutdown) in Tumbleweed I discovered the problem in a log … thread is here Issues with boot sequence, shutdown and reboot

and in my case in the log was this:

Jul 24 18:16:16 stonehenge01 shutdown[2394]: shutting down for system reboot
Jul 24 18:16:16 stonehenge01 init: Switching to runlevel: 6
Jul 24 18:16:17 stonehenge01 kernel:    90.569133] bootsplash: found, but framebuffer can't handle it!
Jul 24 18:16:17 stonehenge01 kernel:    90.569281] [drm] nouveau 0000:01:00.0: Setting dpms mode 3 on tmds encoder (output 2)
Jul 24 18:16:17 stonehenge01 kernel:    90.589503] [drm] nouveau 0000:01:00.0: 0xDDF3: Parsing digital output script table
Jul 24 18:16:17 stonehenge01 kernel:    90.589532] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on tmds encoder (output 2)
Jul 24 18:16:17 stonehenge01 kernel:    90.589538] [drm] nouveau 0000:01:00.0: Output DVI-I-1 is running on CRTC 0 using output A
Jul 24 18:16:17 stonehenge01 kernel:    90.589589] bootsplash: found, but framebuffer can't handle it!

Your problem is DIFFERENT but the gist of this is to take a keen look at the thread at the EXACT time of shutdown. Not 10 minutes or 5 minute earlier.

Again your problem is DIFFERENT so if there are messages in your log files they will be DIFFERENT. (I emphasis this as so many times when I attempt to make such a point about checking a log (and give a different example) a user will come back and say no I don’t see those errors. Like of course one won’t. Their problem is DIFFERENT. They need to look for a DIFFERENT hint at the time of shut down.

I’ve had to do a hard reset the last couple of shutdowns & the system is acting like there are “broken” files. The updater is only half working & I’ve lost all sound, so I think I need to do a system repair. I’ve done that from disk before - but this upgrade was over the wire - so I think I need to download the disk, repair the system, and start over.

I’ve bookmarked the page on the Debian blog & will go through it carefully later. Right now I have to be elsewhere.


well, I don’t know
I let the system remove the sound cards while in as root. I was then able to shutdown without problem.
I opened the system again with a regular ID - had no sound at all, re-applied some updates (some for the 4th time) and was able to shut down.
I reopened the system with a regular ID & everything seems to be fine - sound works, updates have applied, video looks good

It looks like… some problem with the sound card/drivers prevented the system from unloading the drivers to complete shutting down.
I’ve downloaded an ISO image of 11.4 - just in case.

thanks for your help.

On 09/24/2011 11:56 PM, n hand wrote:
> I let the system -remove- the sound cards while in as root. I was then
> able to shutdown without problem.
> I opened the system again with a regular ID - had no sound at all

the way i read that it means you booted, logged into the GUI (KDE,
GNOME, LXDE, Xfce or other) as root, and “removed” the sound card…

then, when you logged out, and back into the GUI as a regular user,
there was no sound…to which i note:

-yes, when you configure the machine as root it will impact all users
every time, and

-you should not log into the GUI as root…that is not the way to make
root level changes to the system…logging into the GUI as root can
cause many many problems…

openSUSE®, the “German Automobiles” of operating systems

Ever since installing the NVIDIA video drivers I’d gotten a lot of error messages about “do you to permanently forget…” and it gave names for 2 sound chips (don’t have a separate sound card). I kept saying no. and I kept having problems shutting down.

In checking through things Friday I noticed Wacom/Linux has stopped providing separate drivers - with my kernel they’re now in the kernel - so I commented some things out of xorg.conf and moved a few more to trash. When I booted yesterday, the system wouldn’t load X, so I logged in as root to fix the problems. Then I started X and got the same *&^% message about “do you want to permanently forget…” so I said yes. Then I had no sound, as root. I closed that session to make sure it would load with my regular ID, still no sound but I was going out, so I shut down the system (YAY! it actually shut down!) and figured I’d look at it later.

I came back and powered the machine up - X loaded AND I had functioning sound under my regular ID.

Yes - I know that changes I make as root are “global”. No, I don’t make a habit of logging in as root.