Can't set keyboard layout in DE


I’m pretty new in Opensuse, but not new in Linux. Did a fresh install of Leap 15.3 and I can’t set my keyboard layout.

I need Polish programmer qwerty layout (the most popular, typical one used by 99% of people here).

Currently when I type Polish diacritics (with letf alt + letter) I’m triggering various DE keyboard shortcuts instead (lock screen, display “start” menu, open Dolphin).

   System Locale: LANG=pl_PL.UTF-8
       VC Keymap: Pl02 # this is incorrectly set by Yast (should be pl) but changing it didn't help either
      X11 Layout: pl
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp


cat /etc/X11/xorg.conf.d/00-keyboard.conf 
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "pl"
        Option "XkbModel" "pc105"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"

I initially started with KDE but it had exactly the same issue. Removed it and installed GNOME, no avail.

I installed briefly IBus daemon and IBus to deselect “Use system keyboard layout”. This doesn’t do anything.

setxkbmap pl

doesn’t help.

YaST2/Set system keyboard doesn’t help.
YaST2/Language set to Polish, field “adjust keyboard layout to language” grayed out.

I found in some official guide that I’m supposed to set the layout from DE but that doesn’t work.

This whole IBus thingy also confuses me. I don’t have it installed, but I saw some libraries of it were used by KDE.

Also not quite sure if Wayland doesn’t go into the way. I’ve been using Xorg system before.

Is it possible to use Linux without english keyboard?

Hi mkkot and welcome to this forum!
That grayed out part seems to be wrong. (I may be wrong, too, as I am still on 15.2.) I can just do some wild guessing - see if there’s a hit? Any of the following packages not installed - may do the trick?


When I invoke

setxkbmap pl

…then when I press the right ALT key and the “l/L” key I get “ł/Ł”. Does that lead you to a solution? Experiment.

Oh man, you can’t be serious. Linux can support almost any keyboard layout that exists, even some local dialects, like in my country it supports or or it can support Dvorak keyboard I say only once someone using it through my entire life but he was like a super nerd.

Thanks for your warm welcome and help, however no luck, everything was already installed.

Now I have another problem – I have to mount usb drives manually despite the fact that my user seems to be added to every group that makes sense.

Since I need this new PC up and running till last Saturday, I guess I will just copy my existing Archlinux there because it simply just work for me.

Ever since I’ve been using openSUSE here in Germany, I’ve used German keyboards and German as the system language –

  • Most of the KDE Plasma users are German language users but –
    *=2]I do have a “very British” language test user, with a German language keyboard –

 > localectl
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: de-latin1-nodeadkeys
      X11 Layout: de
       X11 Model: cymotionlinux
     X11 Variant: nodeadkeys
     X11 Options: terminate:ctrl_alt_bksp
 > inxi --admin --filter --usb
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-7:2 info: Cherry Keyboard type: Keyboard,HID driver: cherry,usbhid interfaces: 2 rev: 2.0 
           speed: 1.5 Mb/s chip ID: 046a:0023 
           Device-2: 1-10:3 info: Logitech M-U0007 [Corded Mouse M500] type: Mouse driver: hid-generic,usbhid interfaces: 1 
           rev: 2.0 speed: 1.5 Mb/s chip ID: 046d:c069 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 

Meaning, my keyboard is a Cherry Linux CyMotion device – with Penguin keys – no Redmond keys … >:)

Please check ‘/usr/share/X11/xkb/rules/xorg.lst’ for the supported keyboard values to be used for your location.

You’ll also have to check ‘/usr/share/kbd/keymaps/xkb/’ for the supported keymap value – for example “pl-dvorak_altquotes” or “pl-dvorak”.

For many years I have used to set the installation language to Slovak during installation, but I always have set the keyboard to English (us).
Then, after the installation is finished and I log into the desktop environment for the first time, I add the local Slovak keyboard.
This ensures a usable layout for terminals outside the graphical environment.