Cant select wireless network

I have installed OpenSuse Leap 15. I was connected using a wired connection. Today I needed to unplug and thought it would be easy.

I selected the network icon in the system tray and it showed me my wireless network. I entered the passcode and voila. No internet. I tried again but now it doesnt snow wireless networks. I went into network configuration selected the wireless ID and made sure the passcode was correct. Still not internet.

I ran rfkill and it shows wlan is unblocked.

How do I select a wireless network and connect to it in OpenSuse LEap 15?

Well I gave up and rebooted and it let me connect. However it prompts me for admin credentials and vault or whatever KDE calls it when I try and connect. How do I stop this?

Hi welcome,

What you’re seeing is the kWallet password manager. To have it not ask you, the simplest solution is to choose Blowfish encryption in the first part of the kwallet dialog, then enter an empty password. After doing so, kwallet will store the network credentials.

Also in Yast - network be sure to change to networkmanager.