Can't see local webpage on Microsoft IIS

A newbie network question.

I am running SUSE Linux 11.2 on my main internet mail machine here and I really like it. Everything seems to be working fine.

On another machine here, I am running Windoze 2000 Pro (don’t laugh) as a home server and I can access the library drive I set up there there just fine through Samba which I set up on the Linux machine.

Also on the server, I am running Microsoft IIS (Personal Web Manager) and have a house home web page set up that anyone can see from any other machine on the network (all Windoze machines, using IE if that makes a difference) by typing:


and the house home webpage I’ve set up shows up in that browser, but not on the Linux machine? Linux (Firefox) takes me to which is a GoDaddy website.

I don’t know how to start figuring out why I don’t see this home page in Linux.

Any clues would be appreciated. Thanks!

The Linux box doesn’t know where <http://server> is, doesn’t know the IP address. You put the IP address in the file /etc/hosts with a line entry like this:

aaa.bbb.ccc.ddd server

Thanks! I suppose that will only work if I nail down the IP of the server? Right now it is not a fixed IP and that seems fine with the Windoze machines. They seem to know how to find it.

If you’re using a DHCP server, then you’ll need to make sure your linux PC has a the IP of the name server configured in order to resolve hostnames to IP addresses, (although I think you’d be better off having the server set up with a static IP).

Your question is an interesting one, and thinking about it a little more, it looks like your home network maybe using multicast DNS like this :: Zero Configuration Networking with Linux

I don’t have experience with this, but avahi is the relevant daemon in openSUSE. Hopefully, others with more knowledge or experience can chip in here…

Thanks deano. I took a look at your link and my eyes clouded over but I am sure that if I studied it…I am a newbie. I have heard of “bonjour” before and of its function. I am not doing anything special or sophisticated with the network here at home, I think it is or was called peer-to-peer networking.

So avahi is what I need to know more about?

Thanks! I suppose that will only work if I nail down the IP of the server? Right now it is not a fixed IP and that seems fine with the Windoze machines. They seem to know how to find it.

The Windoze machines will be using SSDP (similar to mDNS). I’m not sure openSUSE can take advantage of this protocol. So, your choices are

  1. Use Bonjour for Windows with your MS server, and avahi at the linux client end for name resolution.

  2. As swerdna already suggested, add an entry in /etc/hosts, and make sure the server is configured with a static IP address.

  3. If using dynamic addressing (as you currently appear to be even with your http server), make sure that your linux machine can resolve a hostname by including the relevant nameserver IP address in /etc/resolv.conf

I suspect all you have to do to see the server if it has a floating IP is to switch on wins in the file nsswitch.conf. It allows wins to find computers on a lan just by name, a windowsy kind of thing. This is not done by default in openSUSE, probably out of respect for the purity of Linux. But alas this is a real world and we should be more pragmatic IMO.

Open the file /etc/nsswitch.conf and change the pertinent line. Here’s mine to help you:

hosts:          files mdns4_minimal [NOTFOUND=return] wins dns

Make yours like that. Probably have to reboot.

I don’t know if that will work because I have some other windowsy things on my computer, like Samba, but give it a try.

Thanks for jumping in again John. I’m at the limit of my knowledge here.

I wondered if the NOTFOUND status should be adjusted like this

hosts:          files mdns4_minimal [NOTFOUND=continue] wins dns

so that wins and dns resolution are checked if the lookup attempt with the first two methods don’t yield results. Someone please correct me if I’m wrong here. I’m fully aware that slow network response can occur if unecssary lookups (for servers that don’t exist) are configured here, so there may be a better configuration for the OP’s situation.

Edit: From this reference it looks like the ‘continue’ options is by default if there is no NOTFOUND entry.

That’s interesting Dean. I think you’re right about “continue” being the better choice. However in this case both versions work, strange.

I’ve adjusted mine to CONTINUE just out of interest and to see what happens over the next few days.

Adding “wins” to /etc/nsswitch.conf works! I can now see the house home page in linux!

I left the [NOTFOUND=return]

Thanks very much!

You guys are amazing! :slight_smile:

Very glad we could help

Is the IIS server in the w2k PC?
Did you set it up with the default settings (NTLM authentication is on by default)?
If the IIS software is in the win2k box and it was set up with the default options, then you’ll need to ensure that both the samba package and your web browser and email client are the stock opensuse ones (the versions coming from the developper’s website won’t work, opera doesn’t work neither). The reason is that the NTLM authentication system in IIS does a propietary “handshake” that is designed to prevent any non-microsoft browser or email client from accesing contents server through IIS (this archived page explains more about how the NTLM authentication works (note that at the time that page was up microsoft only had that technology in their proxy server software, they added it to their IIS web server software later, also note that originally the NTLM only allowed IE/OE, currently they expanded the list of allowed internet apps to include the web browsers and email clients included in opensuse/SLED/SLES.)).

You obviously know something about IIS since I don’t think I said that the server was a W2K machine - yes it is. I believe the IIS is a stock configuration although it was a while ago that I set it up. The Samba and web browser on the Linux machine here are stock 11.3 although I had a bit of help from the people here on the Samba. At any rate, it all works now.

Question for you. I am thinking about changing the home server to XP. Is there a similar IIS in XP? I have no good reason for switching to XP really, just that if it is newer it must be better (ha!). Or should I just stick with the W2K? If it ain’t broke, don’t fix it!

Yes. There are versions of IIS for windows xp, windows vista and windows 7. Also windows server 2003, 2003r2, 2008 and 2008 r2 comes with versions of IIS preinstalled. As to how do I knew about IIS, well, in your first post of this thread you mention this:

and this:

I knew that IIS was on the windows server because IIS is a windows-only web-server software meant to compete with apache. Also I knew about the NTLM authentication feature because this particular feature was one of the things microsoft did to take netscape out of the market back in mid-90s (remember the NS4-IE4 browser wars). The NTLM authentication feature appeared first in microsoft’s proxy server software (MS proxy), but at late 90s they ported it to the version of IIS that was supposed to ship with windows xp (this was back when it was still called Windows “Whistler”), this version of IIS was later made into a separate app for windows xp and a newer release was added to windows server 2003.

Yes, I did say that! And thank you for the historical update.


Wouldn’t it have been simpler and less prone to complications to just go into IIS and turn on “Anonymous” authentication?


Of course, unless you had a reason to preserve NTLM authentication to keep prying eyes out…