Can't see Cups Printer

Hi all

We have one desktop machine (Ubuntu 8.10) with a Lexmark printer attached to it which we share over the rest of the network. Now normally it’s quite easy “seeing” this printer from other pcs (2 macs and Ubuntu laptop) but for some reason my laptop with Suse 11 just does not want to connect to the printer.

Is there something I need to enable before it will work? What would be a good “route” to take to fish out the problem?

Cheers.

Have you checked your firewall settings?

Without knowing more about your config, some things to check:

  1. Have a look at your CUPS client config in

/etc/cups/client.conf

You will need to make sure it contains a line like

ServerName <hostname or IP address>

Example: ServerName 192.168.70.201

  1. Have you configured the openSUSE firewall so that the CUPS client can see your print server? (Port 631 needs to be open). Configure via YaST -> Security and Users -> Firewall

  2. From a console, type this command:

lpstat -p

What does this return?

From what I can see, the firewall is set to allow all services on the internal network.

client.conf does not have any settings. Do I need to specify the print server’s hostname and IP here?

lpstat -p shows no destinations added.

client.conf does not have any settings. Do I need to specify the print server’s hostname and IP here?

Yes. These may be helpful:

Local CUPS Server

client.conf - Documentation - CUPS

lpstat -p shows no destinations added.

Don’t forget to configure printers via http://localhost:631/

Just realised that the problem is with the firewall (turned it off and it immediately detected the printer in cups). In the firewall settings you can select the “zone” in which you want the network device and realised that my wireless card is not listed.

Any idea why this would be? it works 100% using ndiswrapper. I would prefer not to leave the firewall off.

Thanks.

Revisiting the firewall, did you open the CUPS port?

  1. Have you configured the openSUSE firewall so that the CUPS client can see your print server? (Port 631 needs to be open). Configure via YaST -> Security and Users -> Firewall

Under Service to Allow, you will see ‘cups’ listed. Select it and click ‘Add’,‘Next’ then ‘Finish’ when done.

See, now that is the thing. In the firewall settings, you have a list of Firewall Interfaces (basically your LAN cards). These interfaces have to be set into zones (internal, external, demilitarised). Then you configure the zone to allow cups or what have you. Now the strange things is that it lists my LAN card but not my WLAN (which is what I’m using). So my WLAN connection is somewhere in firewall limbo and it will allow certain things (internet sees to work fine) but some things it will block (like cups and even things like broadcast ping). Now as soon as I turn the firewall off, then everything works 100%

When you first configured your ndiswrapper network interface (via yast network settings), did you assign the interface to a particular zone. If internal (unprotected), this should just work. If in doubt, check the network settings, and edit the zone setting again. Then see if listed in firewall. (I’ve never experienced this problem before). Maybe someone else can offer some advice on this?

Sometimes I wonder about myself. Just went into Network Settings again and realised that next to the wireless adaptor it said “unconfigured”. Don’t really know why as I went into the settings and all was fine, clicked on finish and it restarted the network services and then it was all working … adaptor appeared in Firewall and everything.

These are the days of our lives … strange but true :slight_smile:

Sometimes I wonder about myself. Just went into Network Settings again and realised that next to the wireless adaptor it said “unconfigured”. Don’t really know why as I went into the settings and all was fine, clicked on finish and it restarted the network services and then it was all working … adaptor appeared in Firewall and everything.

Thought this might be the case. Glad its all working. :slight_smile: