can't scan except as root -- xsane on suse 12.1


Today (after some routine software updates) the scanner refuses to work. I get

Failed to start scanner: invalid argument 

from XSANE.

When I log in as root the scanner works well. Also when I use my laptop connected to this scenner.

hardware: HP laserjet 1536dnf MFP
Dell optiplex 790

software: suse 12.1
xsane 0.998
hplip 3.11.10

Thanks for any help…

As xsane is a GUI tool, I guess you not only loged in as root, but you did so in the GUI. NEVER ever log in as root in the GUI.
Please do not start arguing this here. When you think you have the right to log in as root on your own system on your own risk, you are correct. But this is a message to those who are harmless and who, reading this thread, might think that people on these forums advise them to log in as root in the GUI.

And to the point – how do I get the scanner to work again?

To your problem.

When you start (as end-user), do you mean you click from tthe main menu (you forget to tell if you use KDE, Gnome, other)?
When you start from a terminal, what happens then? This because the program complains about an argument given (in the command line). This it is not bad to find out what the argument is. Doing it from the terminal give tthe argument ourselves (non, I would suggest). We cab then look into the menu item to see what call it is using.


I am using the KDE desktop.

Here is the way I tried to scan: start XSANE (with same configuration as when it worked well a few days ago), and press “scan”. This is when I get the error message “Failed to start scanner: invalid argument”.

However: I tried to fiddle with the XSANE program agian just now, and also with SKANLITE. At first SKANLITE also gave an error message. Then I tried to obtain a preview, and that went all right. Suddenly the scan feature started working on SKANLITE. So I moved back to
XSANE, and that too started scanning for me. Presently XSANE seems to work well again.

I don’t know how to reproduce the errors. Any suggestion what to do if the situation returns?

Some of those riddles. I can only assume that some component of the scanning software was replaced by that update and needed to be re-initialised (a bug IMHO). And you did thyat re-inirialising with your experimenting. I assume we will nver know and probably will happen not soon again (updates of just that piece of software will be scarse). And what to do when it haappens again? The same as you described above. :wink:

In any case, your thread is now here to help others that have the same problem. Thus thank you for telling what you did to solve it (even if it isn’t that clear what exactly did the trick).

On 2012-08-24 10:56, amyekut wrote:

> I don’t know how to reproduce the errors. Any suggestion what to do if
> the situation returns?

I had that situation randomly time ago, an older oS version. We tried to investigate it in a
bugzilla, but we could not. Starting xsane as root did work (no need to start the entire
session as root, just from a terminal with “su -”).

I remember that unpluging the scanner, then login out and in, sometimes solved the issue.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)