Can't run java apps with stock 12.1 install

Hi all:
I have a relatively recent Opensuse 12.1 x64 install. Running on an intel processor.

I tried installing eclipse and fiji (another java app) and both apps return the error message: cannot execute binary file. That’s under bash.

Under csh, the error message becomes: Exec format error. Binary file not executable.

Both executables think they are ELF files.

I have OpenJDK installed. Is this a case where you need to install some JVM that isn’t part of the distribution to run things?

Does anyone know other configuration issues that might cause all java apps to fail?

Hello,

I will not be able to help you directly (sorry). But you can improve your posting by not telling stories alone, but backing them with computer facts. Thus everybody can see what you did end what you got. And it spares you a lot of work, because instead of typing things like “both apps return the error message: cannot execute binary file. That’s under bash.” you only have to copy/paste from your terminal (prompt, command, output, next prompt) in one swoop to the post between CODE tags (using he # button in the tool bar).

Same for other things here: “Both executables think they are ELF files.”, but

henk@boven:~> file /bin/bash
/bin/bash: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=0x389a0a8fb3ed548c12ffd2d6a5e212adc804b5a4, stripped
henk@boven:~>

is more informative. Because it does not tell what you think that the executable thinks of itselve, but it tells what tool I used on what and what the results are.

I have 12.2 here, so this is not exactly the same as you, but though I can find eclipse in the OSS repo (in package ecj), I can not find fiji. When this is the same in 12.1 you must have got fiji from somewhere else, but you falied to explain where you installed it from.

Eclipse-swt is not the same thing as the Eclipse IDE (integrated development environment) Eclipse. The only entry in the OSS repository is eclipse-swt, the toolkit.

I have attempted to run two java applications (Eclipse IDE) and Fiji (see fiji.sc) scientific image manipulation software installed from third party websites, not from a repository, because, java applications usually don’t show up in linux repositories. According to what I’ve read from people who package java applications for linux, it’s somewhat tricky and almost pointless because java apps are usually so easy to install.

Both java applications failed to run with the following error message from bash (bourne again shell): “cannot execute binary file”. I with I could give you more information, but, that is the situation.

Using a hexadecimal editor (ghex), I examined the main application file for both applications (filename “eclipse” for eclipse-swt and “ImageJ-linux64” for Fiji The headers for both files begin with “.ELF”, therefore, they are executable files. They contain various java-related error messages in the strings table near the end of the executable file, therefore, they are probably java applications.

Both java applications work on other versions of Linux and are, in fact, major packages in scientific fields. Thus, the problem probably lies with OpenSuse, specifically with java applications.

I suspect that the problem is a lack of an effective java virtual machine with the default OpenSuse installation, but I wouldn’t know because I’m not that good at Java. I’m going to be testing this idea by downloading Novell’s JRE, however, if anyone has the Eclipse IDE working under Opensuse, I could use some help.

to install Sun (oracle) Java you’ll need to follow this guide to get it working properly

https://en.opensuse.org/SDB:Installing_Java

I doubt installing oracle java will help. Both programs work with
openjdk (I use both eclipse and also fiji and plain imagej.
It sounds more as if the starter applications have no executable bit set
or something similar.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.4 | HD 3000
eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

@X61_usr](https://forums.opensuse.org/members/x61_usr.html)
I had this same problem of eclipse not starting when i moved from 32 bit to 64 bit openSUSE
I tried to use 32 bit eclipse on 64 bit
Can you double check your version of eclipse.

On 12/14/2012 09:26 PM, X61 usr wrote:
> installed from third party websites, not from a repository

from those sites did was downloaded source and then compiled locally? or
did they offer .rpm or .bin or .zip files…

did they offer installation instructions for several different versions
of Linux?

if you downloaded an rpm file, did you install it with YaST?

i ask all those questions because there are sufficient differences
between the different distros to require specific installation
instructions…and, if the third party site only provides info for
(say) Debian based systems then…welllll if the installation is
botched, it won’t run…(which i guess is the case here)

[Martin’s runs ok because he knows how to install all of those things on
openSUSE…and, maybe should/could help those third party sites produce
good install directions…or maybe a packager could stuff the bits into
a SUSE-friendly rpm or or or or one could compile from source and i’m
just nearly completely sure it would then work–if one were to compile
and make correctly, for the OS in use…]


dd

I use 64 bit OS (GNOME 3.4.2/openSUSE 12.2)
I can use eclipse(J2EE version) on my system
I have openJDK installed ,also have installed Sun Java from one click from this page, repo is home:enzokiel
I downloaded the eclipse archive using torrent
After downloading i just extract and double click on the executable

YaST
http://i.imgur.com/HZi0Fl.png](http://imgur.com/HZi0F)
Eclipse Works and i am able to get output by running the java program
http://i.imgur.com/oQZ4yl.png](http://imgur.com/oQZ4y)

I did a few simple tests, removing the executable bit from the eclipse
starter application just leads to


martinh@ganymed:~/bin/eclipse37> ./eclipse
bash: ./eclipse: Permission denied

so not the error message which we heard about.

Introducing intentionally a typo to start the application makes it
reproduce the error


martinh@ganymed:~/bin/eclipse37> . eclipse
bash: .: eclipse: cannot execute binary file

(of course as I source now an elf file as if it were a script).

Please X61usr show us exactly with copy and paste how you try to start
the application in a terminal.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.4 | HD 3000
eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server