Can't run firefox anymore

I’m running 11.3 with KDE. I’m not sure when this happened, but I can no
longer run firefox.

If I click on the firefox icon, the bouncing icon appears, runs for a minute
and then disappears. If I actually type in /usr/bin/firefox, nothing happens,
and I get the prompt back in a fraction of a second.

I note that /usr/bin/firefox is a softlink to /usr/lib/firefox/ which
apparently runs the actual executable: /usr/lib/firefox/firefox. I tried
running that directly with exactly the same result.

I can run firefox normally if logged in as root. I can also run it via
/usr/bin/firefox and /usr/lib/firefox/firefox.

I tried uninstalling, reinstalling firefox. No change. I’m running 3.10.xxxx and
the problem may have started with a recent update to 3.10 , but I can’t
be certain.

I downloaded firefox 4.0 beta and it works, but it doesn’t support many addons
(like flash), so it’s not very useful to me.

maybe try removing your .mozilla directory:

rm -r ~/.mozilla

Then see if firefox launches

Yup – that fixed the problem. But what did I delete by removing the directory
that could have caused the problem in the first place??


the .mozilla directory stores all your cookies and history and things like that. I had a similar problem a while ago (Don’t know what caused it) but removing the .mozilla directory fixed it.

BTW never ever run FF as root. This is a big security hole.

Ok thanks for info

If you want to test create a new user level account. This will prove or disprove that the problem is in inauguration files local to the user,

A good way to keep that from happening again:](

And just to add to that - This will clear all your history every time firefox closes so if you want to save URL’s that you browsed in your history add it to your bookmarks