Can't run Akonadi personal Information Management service to run KMail and KAddressBook

I just figured out that I can no longer run KAddressBook and Kmail due to the Akonadi Personal Information Management service not running on the system.

to provide more information, running KAddressBook I get:


> kaddressbook 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString) 
org.kde.pim.akonadiserver: Starting up the Akonadi Server... 
org.kde.pim.akonadiserver: database server stopped unexpectedly 
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection! 
org.kde.pim.akonadiserver: executable: "/usr/sbin/mysqld" 
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/taker/.local/share/akonadi/mysql.conf", "--datadir=/home/taker/
.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid"
) 
org.kde.pim.akonadiserver: stdout: "" 
org.kde.pim.akonadiserver: stderr: "2020-11-07  9:55:35 0 [Note] /usr/sbin/mysqld (mysqld 10.4.14-MariaDB) starting as proces
s 20034 ...
" 
org.kde.pim.akonadiserver: exit code: 1 
org.kde.pim.akonadiserver: process error: "Unknown error" 
org.kde.pim.akonadiserver: Shutting down AkonadiServer... 
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally... 
org.kde.pim.akonadicore: "" 
org.kde.pim.akonadicore: Job error:  "" for collection: QVector()

and running KMail I get:


> kmail 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString) 
org.kde.pim.akonadiserver: Starting up the Akonadi Server... 
org.kde.pim.akonadiserver: database server stopped unexpectedly 
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection! 
org.kde.pim.akonadiserver: executable: "/usr/sbin/mysqld" 
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/taker/.local/share/akonadi/mysql.conf", "--datadir=/home/taker/
.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid"
) 
org.kde.pim.akonadiserver: stdout: "" 
org.kde.pim.akonadiserver: stderr: "2020-11-07  9:43:17 0 [Note] /usr/sbin/mysqld (mysqld 10.4.14-MariaDB) starting as proces
s 15304 ...
" 
org.kde.pim.akonadiserver: exit code: 1 
org.kde.pim.akonadiserver: process error: "Unknown error" 
org.kde.pim.akonadiserver: Shutting down AkonadiServer... 
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally... 
No text-to-speech plug-ins were found. 
Cannot initialize model with data QJsonObject() . missing: QJsonValue(string, "urls") 
org.kde.pim.akonadicore: Job error:  "" for collection: QVector() 
org.kde.pim.akonadicore: Job error:  "" for collection: QVector() 
org.kde.pim.messagelist: Failed to load tags  "" 
org.kde.pim.kmail: ""

Both of which ultimately pop up a prompt to the screen complaining that the Akonadi is not running. So I decided to run the akonadi manually and this is what I get:


r@5510:~> akonadictl --verbose start  
org.kde.pim.akonadictl: Starting Akonadi Server... 
org.kde.pim.akonadictl:    done. 
taker@5510:~> Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString) 
org.kde.pim.akonadiserver: Starting up the Akonadi Server... 
org.kde.pim.akonadiserver: Found mysql_install_db:  "/usr/bin/mysql_install_db" 
org.kde.pim.akonadiserver: Found mysqlcheck:  "/usr/bin/mysqlcheck" 
org.kde.pim.akonadiserver: Using mysqld: "/usr/sbin/mysqld" 
org.kde.pim.akonadiserver: mysqld reports version 10.4.14 (MariaDB) 
org.kde.pim.akonadiserver: Executing: "/usr/sbin/mysqld" "--defaults-file=/home/taker/.local/share/akonadi/mysql.conf --datad
ir=/home/taker/.local/share/akonadi/db_data/ --socket=/run/user/1000/akonadi/mysql.socket --pid-file=/run/user/1000/akonadi/m
ysql.pid" 
org.kde.pim.akonadiserver: database server stopped unexpectedly 
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection! 
org.kde.pim.akonadiserver: executable: "/usr/sbin/mysqld" 
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/taker/.local/share/akonadi/mysql.conf", "--datadir=/home/taker/
.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid"
) 
org.kde.pim.akonadiserver: stdout: "" 
org.kde.pim.akonadiserver: stderr: "2020-11-07  9:59:21 0 [Note] /usr/sbin/mysqld (mysqld 10.4.14-MariaDB) starting as proces
s 21442 ...
" 
org.kde.pim.akonadiserver: exit code: 1 
org.kde.pim.akonadiserver: process error: "Unknown error" 
org.kde.pim.akonadiserver: terminating connection threads 
org.kde.pim.akonadiserver: terminating service threads 
org.kde.pim.akonadiserver: stopping db process 
org.kde.pim.akonadiserver: Shutting down AkonadiServer... 
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...

I tried Googling for a way to fix the issue but frankly ended up more lost than I was before I started. I have some important information on the KAddressBook and KMail that I don’t want to have to delete to fix this issue.

I am not quite sure, but I believe this occured after my upgrade to the 20201023 snapshot from the 20201007, but I could be wrong. Either way I should be able to confirm in a few hours as I have a pretty much identically configured laptop at home which I also upgraded last night that I can check for the same issue when I get home in the afternoon.

thanks.

Confirmed. I have it since few days. Korganizer not working. Starting akonadi ends failed


kacior@linux-4fuo:~> org.kde.pim.akonadiserver: Starting up the Akonadi Server...

org.kde.pim.akonadiserver: database server stopped unexpectedly 
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection! 
org.kde.pim.akonadiserver: executable: "/usr/sbin/mysqld" 
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/kacior/.local/share/akonadi/mysql.conf", "--datadir=/home/kacior/.local/share/akonadi/db_data/", "--socket=/run/use
r/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid") 
org.kde.pim.akonadiserver: stdout: "" 
org.kde.pim.akonadiserver: stderr: "2020-11-07 21:20:12 0 [Note] /usr/sbin/mysqld (mysqld 10.5.6-MariaDB) starting as process 28689 ...
" 
org.kde.pim.akonadiserver: exit code: 1 
org.kde.pim.akonadiserver: process error: "Unknown error" 
org.kde.pim.akonadiserver: Shutting down AkonadiServer... 
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...

Mysqld[mariadb?] working properly


[FONT=monospace]systemctl status mysql.service  
**●** mariadb.service - MariaDB database server 
     Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled) 
     Active: **active (running)** since Sat 2020-11-07 18:46:08 CET; 2h 42min ago 
       Docs: man:mysqld(8) 
             https://mariadb.com/kb/en/library/systemd/ 
    Process: 1020 ExecStartPre=/usr/libexec/mysql/mysql-systemd-helper install (code=exited, status=0/SUCCESS) 
    Process: 1045 ExecStartPre=/usr/libexec/mysql/mysql-systemd-helper upgrade (code=exited, status=0/SUCCESS) 
   Main PID: 1051 (mysqld) 
     Status: "Taking your SQL requests now..." 
      Tasks: 9 (limit: 4915) 
     CGroup: /system.slice/mariadb.service 
             └─1051 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --user=mysql 

During last update i noticed that mysqldb was migrating to newer version. Something may be broken. Have no time last time and couldn’t report it earlier.
[/FONT]

I too can confirm (again) that this is certainly an update related issue as I checked the laptop at home which I update in lock step with the one at the office and it too has the exact same issue.

Just wanted to let everyone know that the issue was resolved after updating to the “20201106” version / snapshot.

Not really. 20201117 and still have a problem

I just did drop the whole db. I was tired of this…