Can't resolve host for yast2 in console

Hey guys,

It’s been a while since I’ve use linux (specifically suse). But my wife and I are expecting our first child and our office/second bedroom is now being converted into the baby room. I built the computer that is currently in there and it is a really nice one that I do not want to get rid of. Two 500GB Sata2 drives and 8Gigs of RAM (not to mention my quad-core Phenom AMD processor and sweet asus motherboard) – I just can’t get rid of it. So what I planned to do was turn it into a small home server. I did some research and kept coming back to using opensuse as the server. I read this article The Perfect Server - OpenSUSE 11.4 x86_64 [ISPConfig 2] | HowtoForge - Linux Howtos and Tutorials and it seemed to have just about everything I’d like to do (maybe some extras that I don’t really need, but might in the future). Everything was going fine until I got to a certain point. The install went fine, and I was starting to customize some of the settings for my own home setup. Now, the problem…

I’ve gotten to page 3 of the tutorial The Perfect Server - OpenSUSE 11.4 x86_64 [ISPConfig 2] - Page 3 | HowtoForge - Linux Howtos and Tutorials

and I am installing packages through yast2, and all the packages installed fine except for ‘compat-readline4’. I think this is a form of command line editor or something to do with that. I am sure I am going to need it to finish the server set up, but I can’t get it installed anywhere. I’ve tried to install it by pointing directly to the mirror found at and still I get nowhere.

Yast2 auto refresh seems to fail everytime I run it. Even though I installed all the other packages, I get an error message that says it can’t get the medium. When I look at the details of the error it says it can’t resolve the host for

I don’t know what to try, and any help would be greatly appreciated. My wife is trying to set up the room right now, and I don’t want to pack up all the computer stuff until I get everything finished. I hope someone can give me some advice. Thanks in advance.

Three possible issues spring to mind if a repository’s host can’t be resolved, one being a problem with network connectivity which wouldn’t be the case if it was only one repository and the others refresh without a problem

A second reason could be that sometimes a repository can be ‘down’ and there isn’t much you can do about that except keep trying until it comes back up

A third reason being incorrectly configured repositories

As for packages from sites like rpmbone I would steer well clear of them unless you really know what you’re doing, but even if I can’t find a package in suse’s own repositories (a rare thing) then personally I would install from source.

The package you are looking for is in the openSUSE:11.4/standard repo, either manually add Index of /distribution/11.4/repo/oss/suse to your repository list or do a search for compat-readline4 in the Package Search box on the page Download openSUSE 11.4

You will find download links to the rpms or if you have a DE installed there is also the ‘1-click install’ option, the 1-click installs do add repositories though so use with caution

You missed one :slight_smile: …The CD/DVD entry in the repos…
Yast - Software - Software repositories
Remove the CD/DVD entry.

Most of the times this solves the problem.

Thanks for the advice guys. I tried the simplest thing first which was to disable the CD/DVD repo and I got the same error. It’s very strange…It’s almost as if I don’t have internet connectivity, which is crazy because I’ve already downloaded and installed several other packages.

Let me be specific in my error code, which may help. When I try to install “yast2 -i compat-readline4” I get the following error:

Download (curl) error for ''
Error code: Connection Failed
Error message: Couldn't resolve host ''

If I skip the error I get another error that says it cannot copy the package compat-readline4 to a temporary repository, then another one right after that says it can’t find it on the medium.

I tried manually adding the repository like Ecky suggested and I get another connection error for It makes me feel like there was some sort of setting messed up for my connection.

I did just notice that the files are on the DVD that I made…so I may end up trying to install directly from there…however, if there is a bigger issue with my connection or the lack of being able to have up to date repositories…I’m going to need to get that fixed soon. Any more thoughts? Thanks guys!

There are a few things to try,

dig to check DNS, if it gives a answer try,

ping may not get a response. or


The dig command (or nslooup) will search DNS and return a IP address then the other
commands will show if there is connection.

dig’s output:

global options: +cmd
connection timed out; no servers could be reached

ping’s output:

ping: unknown host

traceroute’s output: Name or service not known

Ok, so somehow I don’t have connection. Now that I am thinking about it, the packages that I previously installed without any problems might have came directly from the DVD I had just installed from. Since I literally started working on the server set up from the guide, I didn’t take out the DVD. Could one of the options I set in my network have made the connection close? I wouldn’t know how to tell without just reseting my network settings to default DHCP.

Start again without using HowToForge. It is necessarily complicated, and is intended to build a server for an ISP using particular tools for managing rented mail and web hosting customers. If you have followed the guide you have probably disconnected from your LAN and/or not have an effective nameserver.

You are probably primarily interested in a LAN fileserver, and a small number of mail users and webservers (perhaps for multimedia streaming). It is much easier to follow the openSuSE installation prompts, get a working server, and then tune it to your specific requirements. If you have a screen and keyboard attached to the machine, the standard installation tools are much more pleasant to use than the purely text mode. Also there is a lot of support and documentation for openSuSE compared to a HowToForge special.

The first thing is to be clear about what you want the machine to do, and then how to use the availble disk space.

Whats the output of ifconfig and netstat -rn?

Also cat /etc/resolv.conf

On 09/05/2011 03:16 AM, eng-int wrote:
> Start again -without- using HowToForge.

at the very very least do not proceed to anything not in the universe until after all updates are completed…

reason: 11.4 as it exists on the CD/DVD did have a small problem doing
all the required package management duties of YaST…those were soon
fixed…if one starts ‘customizing’ before then, expect problems…

second reason to shy away from ‘perfect’ instructions on anything
openSUSE not in is because you have (and no one has) any
idea of whether or not the openSUSE community agrees in anyway that it
is the way to go today (maybe the tutorial was great the day 11.4
was released, but does it now need to be updated in some way? has it been??)


Thanks for the advice guys. I should have just followed some of the more authentic opensuse documentation, but the guide seemed pretty straight forward. I still don’t want to run a DE because I have had problems in the past with compatibility issues with my motherboard and the nVidia driver on it. I didn’t feel like getting involved with it. Also, once I have my box set I am no longer going to have a keyboard or monitor hooked up to it. I am just going to ssh to the server whenever I need to make an adjustment.

What I will do is look up some documents for specific needs and just do these installs and setups one at a time from the opensuse site and that will work fine. I must have made some kind of a mistake somewhere that I didn’t see. I re-installed the server and the connection seems to have come back. Yes! Now on to the rest of the stuff before my wife throws my computer out of the window for taking much longer to set up than I originally told her :smiley:

Ah yeah! My bad, but then again …

He was asking about an issue with resolving the host of a remote repository and I kinda figured his dvd drive would be local :stuck_out_tongue_winking_eye:

HolyShnikes dunno how long it is since you tried a DE with your nvidia card but support’s come a long way in the last couple of years, I’ve opensuse running on machines with various cards from geforce 5xx agp up to pci-e geforce gts250 with either kde, lxde or both

As for not planning on plugging in a keyboard and mouse doesn’t necessarily make an installed DE pointless, sometimes it’s just plain more convenient to use an X app or even an entire desktop and you can do both over ssh from another machine. I tend to run dolphin, kate & yast2 quite frequently over ssh and occasionally use a disconnected nx session if there’s an X app I wanna keep running on a server without being ‘actively’ logged in

I agree with what’s been said about the howtoforge perfect setup tutorials but ken_yap pointed me to a mail server setup how-to ages ago that has been kept updated and I found very helpful in intially getting things up and running which is found on Welcome to |

They are aimed at debian so can’t be followed to the letter right the way through, package names differ sometimes, stuff like that, but the principles of how to go about it are sound so it’s a decent guide on how things work and steps to take

I also had this problem, installing with vmware workstation 7. Solved finally by setting DHCP (automatic ip) in yast2. Setting router to DMZ at ip’s of physical computer. Changing Ip4 to fixed in the physical and NAT connection type in virtual VmWare machine (same ip as physical computer).

On 2012-07-31 12:06, CarlosSan wrote:
> I also had this problem, installing with vmware workstation 7.

Please notice that you replied to a thread a year old.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I know, But I supposed that just like I arrived here (and no solution was valid) others would come here and find useful this little bit of info.
Thanks anyway.
In step 7, a similiar problem happened executing “yast2 -i bind bind-chrootenv bind-devel bind-utils”
And to solve it I had to go back to root directory before executing that. Just typing “cd” 'course