Can't Resize Windows Partition

The openSUSE 11.2 installation disk doesn’t want to let me resize my NTFS-based WinXP partition; it just says that the fs is inconsistent and that I should check this issue in windows… But even though I’ve scheduled diskcheck to run after a reboot, it doesn’t!!! Is there some way of “forcing” the diskcheck to run upon startup, or how else can I resolve this issue (without re-installing my entire system)?

How did you schedule a disk check in Windows?

Also you should go into Windows and do a defrag. And if the swapfile is at the end of the partition you need to move it up so that it won’t get in the way of shrinking the partition.

To add you should disable the windows pagefile then defrag.
Don’t enable the pagefile until the windows partition is shrink.

I disabled the pagefile and ran a full defrag, but the installer still says the same thing. So I tried to manually edit the partition, and it told me that 2 clusters were referenced multiple times, and to run chkdsk /f from windows and reboot 2 times. Following these instructions, I ran cmd with full administrator rights, and executed chkdsk /f It told me that it was unable to scan the disk, as it was in use by the OS, and asked if I wanted to schedule it to run after the next reboot; and though I selected yes, and it told me that it had scheduled it to run, the computer merely booted into windows right after I told it to restart! Why is this happening, and how do I fix this?

Maybe boot to safe mode and run chkdsk /f ?

Just tried it in safe mode, no change whatsoever.

Try opening up a DOS command window and running chkdsk /f from that.

If you have a windows install disc can you boot from that and find the option to run a CLI from here, this way your partition is not mounted.

Running chkdsk from the windows installation disk did the trick! Thanks dvhenry! :slight_smile:

I am pleased to see that the combination of advice offered here led to success.

I hope the rest of your install completed smoothly. Enjoy OpenSSUSE! I certainly do!